[SOLVED] Can't Use NFS Share

Discussion in 'Proxmox VE: Installation and configuration' started by Keyninja, Apr 16, 2019.

  1. Keyninja

    Keyninja New Member
    Proxmox Subscriber

    Joined:
    Apr 15, 2019
    Messages:
    8
    Likes Received:
    0
    So, after getting this error "mkdir /mnt/nfs-backup01/images: Permission denied at /usr/share/perl5/PVE/Storage/Plugin.pm line 954. (500)" when trying to add my NFS share on FreeNAS for backups, I manually added the server via "pvesm add nfs backup01 --server=10.x.x.x --export=/mnt/pool01 --path=/mnt/nfs-backup01". Once I had that added, and it did at least add without errors, I get the same "mkdir /mnt/nfs-backup01/images: Permission denied at /usr/share/perl5/PVE/Storage/Plugin.pm line 954. (500)" When I navigate to that storage device under one of the nodes in the Web UI. Any ideas out there?
     
  2. Keyninja

    Keyninja New Member
    Proxmox Subscriber

    Joined:
    Apr 15, 2019
    Messages:
    8
    Likes Received:
    0
    I've self-resolved! In FreeNAS, under the share settings, I experimentally set the mapall users setting to root, which makes anyone using that directory access it with root permissions. The issue then went away, giving me full access to the share. To further lock down the security, I created a "Proxmox" user with write permissions, and mapall-users'd that user to the share. Issue resolved!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice