can't connect to internet

simon_smith

New Member
Sep 16, 2020
4
0
1
Hi,

I really hope somebody can help me. I'm new to proxmox and after successfully testing my workloads on it, I moved some important projects to the server and suddenly proxmox decides to stop working and now i can't access my data nor do i know how to retrieve it. I really hope i don't have to reinstall.
Before things went haywire i was adding network cards to a newly created vm so i could install pfsense. On the router side, no show of connection to the server and i can't access the web gui.

Running:
proxmox 5.4.34-1-pve

I've tried:
ping proxmox itself
Ouput: Temporary failure in name resolution

ping 8.8.8.8
Output: Destination host unreachable

Interestingly "pvesh get nodes" show my node's status as "ONLINE", cpu and mem usage and ssh cert.

please let me know of any details you need in order to have a better picture.
Thanks a lot!
 

simon_smith

New Member
Sep 16, 2020
4
0
1
Hi Moayad,

Thanks for your response. I gave up trying to fix /etc/network/interfaces (i tempered with it quite a bit but learned a few things in the end) and made a fresh installation on an internal flash driver. I proceeded to retrieve my data and managed to mount old drives (some as LVM, LVM-Thin but the majority as Directory... i'm yet to understand why).
I can see the old vms on the drives but i'm lost as to how to import them so they are usable. I would greatly appreciate it if you could help here.
 

simon_smith

New Member
Sep 16, 2020
4
0
1
No, Datacenter -> Storage -> Add -> LVM/Directory and for volume group i selected the archived pve-old-...
I can confirm that all the disks are listed and mounted to the node UI.
I followed Udo's advice here (emphasis on last answer) but i'm stuck with this error:

mount: /mnt: wrong fs type, bad option, bad superblock on /dev/mapper/pve-data, missing codepage or helper program, or other error.
 

Moayad

Proxmox Staff Member
Staff member
Jan 2, 2020
585
50
28
27
Vieena
shop.maurer-it.com
Hi,

Please open up a new thread and explain your issue, with the current PVE version pveversion -v and output of the following commands:

Code:
lsblk -f
lvs -a
vgs -a
cat /etc/pve/storage.cfg
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!