[SOLVED] Broken GPU passthru after PVE Upgrade (5.4 -> 6.0)


Feb 12, 2019

I've been successfully using GPU passthru to a Windows 10 VM with PVE 5.x. No problems at that point.

But some days ago I upgraded from PVE 5.4 to PVE 6.0 and now the VM doesn't manage to start Win10 OS. The exact behaviour when I start the VM is that I see Proxmox's UEFI splash image (in the monitor attached to GPU been passthrown), then UEFI launches Windows boot (I can see the circle with moving points) and shortly after that, monitor goes black and loose signal. Then it recovers signal and I can see again UEFI splash image, etc. I don't know the exact reason but my guess is that Windows boot is interrupted just when trying to enable nvidia driver and then it gets some kind of BSOD/crash. After 3 times-cycle, I'm offered the Windows recovering menu. Sometimes, Windows manages to boot up and run and in this case, it uses standard VGA driver,not nvidia one (in device manager I can see nvidia device failing with the well-known "error 43" :-(

Anyone experimented a similar GPU passthru problem, specially with pve 6.x?

The weird thing is that my setup worked perfectly with pve 5.x so something in 6.x should have caused the problem. Changes from 5.x to 6.x includes:
- kernel 4.x -> 5.x
- qemu 2.6 -> 4.0
- many other things

I've been extensively reviewing/testing with no luck (I'll update this post if I get some clue) and I'll keep doing more testing.

Ideas are welcome :) .Perhaps I'll try with an older qemu. Or perhaps I could find any info in Windows (I can boot it if I disable passthru and use VNC console) regarding the potential crash (any clue where to exactly look at?).

Thank you in advance for your time. It's much appreciated.

PS: My hw setup is HP Gen8 Microserver (motherboard) + nVidia Geforce GT 710 (GPU passthru). My sw setup is the typical one (enabling IOMMU, etc...) following Proxmox's Wiki as well as tons of other advices/blogposts/etc. One pecualirity is that I'm only passing-thru 07:00.0 device (VGA device), not 07:00.1 (HDMI Audio), which of course I had to place in different IOMMU groups. That's due to some incompatibility with my motherboard's BIOS which prevented to be able to pass the audio device (according to some post which I don't remember). Despite that, all this setup was working ok with PVE 5.x. I can go deep and provide more details regarding my configuration, if needed.
Last edited:
I hadn't seen that thread but indeed, that was exactly the problem!! Thank you so much!!!!

Now it is SOLVED with a simple:

qm set ID -args '-machine type=q35,kernel_irqchip=on'

Another summary thread:
Fix for PCI-passthrough and issues with Proxmox 6 GUI REGEX that needs resolving after upgrade

As some others pointed out, a reference to this nasty issue should have been already added to Proxmox's Wiki since the first step people like me (who suffer the issue) do is reviewing GPU Passthru configuration (thus, we also review Wiki page).



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!