[SOLVED] Backup lxc Container from pve 4.4

another_dave

New Member
Sep 15, 2020
11
1
3
21
Hi, might sound a little stupid, but I am searching on Google since yesterday evening and don't know if I just search wrong.
I tried to Upgrade my Proxmox from 4.4 to 6.3
So i backuped my VM and my Containers (via WebGUI) and tried to upgrade the Server. Well, this went horribly wrong, and basicly all my pve Services died, and are masked now.
So i made a new Server, scp'd the backups in, and tried to implement them. VM worked fine, but the containers seemed to be corrupted, at least gzip cant unzip them anymore, and ARK won't open the tar.gz Files either.
Now i want to get another backup of my Containers, but i can't access the WebGUI, pct as a command is not available and I don't know where the containers are mounted.

Can someone help me with this, or did i crash my System a little too hard, to restore the containers?
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
3,389
388
88
hi,

vzdump CTID will create a backup. you can see man vzdump for all the options
 

another_dave

New Member
Sep 15, 2020
11
1
3
21
hi,

vzdump CTID will create a backup. you can see man vzdump for all the options

Well, I had to manually install vzdump, and it won't recognize any of my Containers. But i just now the name of them, or isn't that the ID?
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
3,389
388
88
you need to give the ID to it
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
3,389
388
88
pct list will give you the IDs
 

another_dave

New Member
Sep 15, 2020
11
1
3
21
Got it
After noticing that pve-manager wasn't installed anymore, and i couldn't install it again (because of broken packages), i found a new solution without losing any data.
If someone encounters a similar Problem, try re-installing the whole pve (Maybe with a backup :D)
In my Case, it just fixed the broken update, and I got a seemingly stable 5.4 PVE Version. By doing this, I could simply create a new backup threw the GUI and it didn't kill my *.tar.gz

Here the installation manual I used. Look at point 3: Install Proxmox VE
https://pve.proxmox.com/wiki/Install_Proxmox_VE_on_Debian_Stretch#Install_Proxmox_VE

I simply overhauled the whole system and it worked again. Still I will just create a backup and put it on a new Proxmox
 
  • Like
Reactions: oguz

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!