backup is not taking in proxmox

jegan

New Member
Jul 27, 2020
20
0
1
28
Hello,

root@proxmox1:~# pvesm add pbs < storage name > --server < backup server ip > --datastore < datastore > --username root@pam --fingerprint 1d:..43:ee --password < backup server password >

I add the pbs in proxmox cluster, It's has added properly I didn't face any error,
But while I am taking the backup then I getting this error,

INFO: starting new backup job: vzdump 105 --mode snapshot --remove 0 --node proxmox3 --storage backupserver --compress zstd
ERROR: Backup of VM 105 failed - executable not found '/usr/bin/proxmox-backup-client'! Proxmox backup client not installed?
INFO: Failed at 2020-09-22 20:42:00
INFO: Backup job finished with errors
TASK ERROR: job errors

root@proxmox1:~# pvesm status --storage backupserver
executable not found '/usr/bin/proxmox-backup-client'! Proxmox backup client not installed?
Name Type Status Total Used Available %
backupserver pbs inactive 0 0 0 0.00%
 
Last edited:

dylanw

Proxmox Retired Staff
Retired Staff
Jul 6, 2020
373
72
28
Hi,

It seems that you have not installed proxmox-backup-client on pve.. Try running 'apt update && apt install proxmox-backup-client.
 
  • Like
Reactions: fel0xleo

mbaldini

Active Member
Nov 7, 2015
170
21
38
Perhaps do you have an old version of PVE?
Have you tried to
Code:
apt update
apt full-upgrade
?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!