Windows Server 2022 - Das System wurde unerwartet heruntergefahren

itNGO

Well-Known Member
Jun 12, 2020
526
114
48
44
Germany
it-ngo.com
Wir haben an allen Intels jetzt das Intel-Microcode installiert und mitigations=off sowie bei den AMDs auch auf mitigations=off gesetzt.
Bis jetzt sieht das ganz gut aus mit aktuellem Kernel.... Ist allerdings auch kaum 24 Stunden her.....
 

IT-MCSE

Member
Nov 7, 2020
45
4
8
46
Falls es wen interessiert:
An all unseren PVE´s ist 5.15 in Betrieb und wir haben nicht diesen beschriebenen Fehler.
An den AMD Milan´s ist alles original.
An den Intel´s ist einzig
Code:
intel-microcode
und
Code:
mitigations=off
aktiviert.
Die Intel´s sind querbeet,von E3 über Gold usw... Auch die VM´s sind sowohl von Hyper-V migriert oder neu erstellt. Alles dabei.
Das hat doch direkt auf die CPU Einfluß ( Update ) oder verstehe ich das Falsch ?

Das kann bei meinem System ( Supermicro = secure bios ) spannend werden.

Soll das wirklich die Ursache dafür sein, kann ich mir nicht erklären warum. Aber vielleicht ist es wie schon hier erwähnt erstmal ein Workaround.

Für mich macht da aber der vorübergehende Kernelwechsel mehr Sinn ;)

Aufjedenfall ist die erste Win22SRV gestern wieder offline gegangen ( 1 von 8 Maschine ) und wieder der Hardware KVM Fehler.
 

ITT

Active Member
Mar 19, 2021
205
49
28
41
Das hat doch direkt auf die CPU Einfluß ( Update ) oder verstehe ich das Falsch ?

Das kann bei meinem System ( Supermicro = secure bios ) spannend werden.

Soll das wirklich die Ursache dafür sein, kann ich mir nicht erklären warum. Aber vielleicht ist es wie schon hier erwähnt erstmal ein Workaround.

Für mich macht da aber der vorübergehende Kernelwechsel mehr Sinn ;)

Aufjedenfall ist die erste Win22SRV gestern wieder offline gegangen ( 1 von 8 Maschine ) und wieder der Hardware KVM Fehler.
War ja nur meine Schilderung von unseren Systemen.
Weder die Clustersysteme, noch Standalone-Hosts zeigen diese Fehler (gottseidank!)
Und wie gesagt, die AMD´s sind original, die Intels alle mit dem microcode installiert und mitigations deaktiviert.
 

itNGO

Well-Known Member
Jun 12, 2020
526
114
48
44
Germany
it-ngo.com
@itNGO
Bitte weiter reporten, vielleicht entwickelt sich das ja zu einem Workaround :cool:
GO für Intel/AMD-Microcode + Mitigations=off mit Kernel Linux 5.15.35-1-pve.

An die Anpassung in der "/etc/modprobe.d/intel-microcode-blacklist.conf" denken! Sonst wird der Microcode nicht geladen!

48 Stunden stabil jetzt....
 

mayli

New Member
May 17, 2022
3
0
1
Nachdem Win22 ein bis zwei Mal am Tag abschmiert hab ich nun auch Intel Microcode installiert u. Mitigations=off gestellt.
Leider hat sich dadurch aber nichts geändert.
Was muss ich bei Microcode einstellen?
Kann mir da bitte jemand weiterhelfen. Danke!
 

IT-MCSE

Member
Nov 7, 2020
45
4
8
46
Ich habe 2 Host´s mit unterschiedlicher Hardware am Laufen.

Der erste:
1654578589394.png

Der zweite:

1654578684204.png

Beide Maschinen haben Win11 bzw. Win22SRV als VM pc-q53-6.1 installiert. Bei beiden kommt es zu ausfällen der VM´s und immer mit dem Hardwarefehler KVM. Der Fehler ist zwar immer der selbe, aber die Laufzeit bis er auftritt variiert stark. Manche VM´s laufen 2 Wochen, manche 1 Woche. Bis jetzt kam es erst einmal vor das ein und die selbe VM in einer Woche zweimal "starb". Wird spannend sein, diesen Fehler genau zu reproduzieren.

Für mich gilt daher: zurück auf Kernel 5.13 ( da war der zweite Server vorher und es gab keine Ausfälle ).
 
Last edited:
Jan 27, 2022
25
4
3
48
Nur nochmal als Rückmeldung. Nach gut 14 Tagen Laufzeit hat es nun einen meiner beiden Testserver auf dem neuen Kernel geschmissen. Das es mal 2 Wochen gut läuft ist also keinesfalls eine Sicherheit, dass der neue Kernel läuft.
Auf dem 5.13. Kernel laufen alle Server auch nach 3 Wochen noch.
 
  • Like
Reactions: itNGO
Jan 27, 2022
25
4
3
48
Es ist ruhig geworden hier...gibt es schon ein Update, dass das Problem löst? War in Urlaub und habe das Ganze nicht so Recht verfolgen können. Was ich sagen kann ist, dass alle VMs mit dem 5.13er Kernel stabil laufen.
Hat sonst wer neuen Erkenntisse?
 
Jan 3, 2022
10
4
3
München
wie schon geschrieben betriffst es bei mir ja nur die Kunden die importierte VMs von Hyper-V haben. Neu installierte Windows VMs (Server 2019/2022) sind nicht betroffen. Auf älterer Hardware tritt das Problem ebenfalls nicht auf. Erstaunlich dass seit Mai seitens Proxmox keine Information dazu kommt.
Alle Hosts mit importierten Windows VMs laufen mit dem 5.13 Kernel stabil, aber man darf eben Proxmox nicht updaten :-(
 
Last edited:

itNGO

Well-Known Member
Jun 12, 2020
526
114
48
44
Germany
it-ngo.com
wie schon geschrieben betriffst es bei mir ja nur die Kunden die importierte VMs von Hyper-V haben. Neu installierte Windows VMs (Server 2019/2022) sind nicht betroffen. Auf älterer Hardware tritt das Problem ebenfalls nicht auf. Erstaunlich dass seit Mai seitens Proxmox keine Information dazu kommt.
Alle Hosts mit importierten Windows VMs laufen mit dem 5.13 Kernel stabil, aber man darf eben Proxmox nicht updaten :-(
Es gibt vergleichbaren Thread im englischen Forum, und da ist auch Rückmeldung von Proxmox. Die sind da dran..... einfach etwas Geduld haben... die Nutzung des 5.13er Kernels ist aktuell ja noch ein supportetes Szenario. Mit KernelPIN kann man die restlichen PVE-Updates ja dann trotzdem installieren....
 

mira

Proxmox Staff Member
Staff member
Aug 1, 2018
1,774
195
83

anjo

Member
Feb 24, 2020
15
1
8
51
Ich habe eine neue Erkenntnis. Gestern ein System wegen angeblicher langsamer Performance analysiert. Version 6.4.14. Lief immer total stabil. Habe dann statt der virtio win driver 208 die aktuelle 2.17 v2 eingesetzt. Und siehe da, Win10 und Server 2019 abgeschmiert. Es kann also nicht nur am Kernel liegen. Ich bin dann so vorgegangen. Balloon Treiber habe ich aktuell gelassen (Mai 2022), aber den Guest Agent mit 215 installiert. Läuft nun wieder stabil
 
Last edited:

anjo

Member
Feb 24, 2020
15
1
8
51
Ich habe den Kernel nicht gewechselt, jedoch eine andere Sache gefunden. Der Windows Defender Dienst - immer wenn er sich meist in der Nacht eingeschaltet hat, ist die Kiste abgestürzt. Zuletzt täglich. Ich habe den Defender per Power Shell entfernt. Jetzt läuft es. 2 andere Windows Server 2022 machen das allerdings nicht. Ich dachte erst, dass Norton Security etwas damit zu tun haben könnte, jedoch läuft ein anderer stabil damit. Vorher lief der mit dem April Kumulativ Update auch nicht und stürzte ab.
 

Attachments

  • image1.jpg
    image1.jpg
    122.5 KB · Views: 6
  • image2.jpg
    image2.jpg
    53.8 KB · Views: 7

IT-MCSE

Member
Nov 7, 2020
45
4
8
46
Also ich habe auf einer Maschine -wie gefühlt vor Ewigkeiten geschrieben- immer den neuesten Kernel laufen. Es kommt nicht mehr so häufig zum Absturz der 2x WIN22K Srv. Einer läuft seit 19 Tagen, der andere ist vor 6 Tagen stehen geblieben. Die weiteren Win11Pro Maschinen ( 6 stck. ) ebenfalls nur eine die vor 9 Tagen stehen blieb. Für mich ist das nicht eindeutig, außer der "KVM Fehler" immer wieder. Klingt also für mich nach einem Kernel und KVM Thema. Den Workaround habe ich noch nicht getestet. Werde ich aber am WE mal machen und berichten.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!