Windows 10 VM under Proxmox unable to connect to a VPN

scarlaxx

New Member
Mar 15, 2021
5
0
1
50
Hello. I'm new to all this Proxmox, Linux, I learn this wonderful software as I go so my apologies if I miss something basic.
I've recently made a VM running a Windows 10 Pro 64bit. This virtual machine can access the internet, dns lookup works for the configured VPN hostname yet is is unable to connect to any VPN. Firewall is switched off in windows, no networking rule applies infrastructure-wise from Proxmox machine up to the internet.
I've already checked 3 VPNs on the same VM, none of them work. Tried with a different computer running the same Windows version and VPN configuration, all 3 of them work just fine.
HW settings screenshot for the VM is attached.
I was unable to google anything rly useful which either means I google with a wrong query or it is not a common issue.
Please advice whether I should search for the issue on the Proxmox side of things or in Windows.

Thank you!
 

Attachments

  • WindowsVMHardware.jpg
    WindowsVMHardware.jpg
    43.6 KB · Views: 13

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,207
676
118
hi,


yet is is unable to connect to any VPN
at which stage of connection does it fail? what error message do you get?

also what vpn client is in use?

you could also try changing the network interface type to e1000 or virtio
 

scarlaxx

New Member
Mar 15, 2021
5
0
1
50
Hello and thank you for your reply. I was in abroad so sry for my late reply.

at which stage of connection does it fail? what error message do you get?
It takes cca half a minute of trying and at the end it says: 'The network connection between you computer and the VPN server could not be established because the remote server is not responding. Ths could be ...' blah blah about firewalls, NAT etc. The same VPN settings work on another computer running the same windows version

you could also try changing the network interface type to e1000 or virtio
So far I tried switching to both, also tried to disable the firewall checkbox in proxmox NIC settings for VM. No effect on anything. Interestingly, I can ping the VPN server with any of the settings combination within around 15ms time.
also what vpn client is in use?
I'm not sure how to answer this. I'm using default built-in windows client with manual VPN settings.

Thank you
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,207
676
118
* what is the output of ipconfig /all from your windows VM?

* maybe also try running tracert your.vpn.ip.address

* is VPN using TCP or UDP connection?
 

scarlaxx

New Member
Mar 15, 2021
5
0
1
50
IpConfig and tracert outputs attached.
VPN is of type PPTP if that helps as I have no idea how to tell it uses TCP or UDP.
 

Attachments

  • ipconfig.txt
    1.2 KB · Views: 1
  • tracert.txt
    1.3 KB · Views: 2

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,207
676
118

scarlaxx

New Member
Mar 15, 2021
5
0
1
50
Thank you again oguz but after I spend a couple of hours on this issue I installed a different VPN client provided by a company I work for. That client works with a different VPN settings so I will stick with that.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!