[SOLVED] [Warning] Ceph Upgrade Octopus 15.2.13 to Pacific 16.2.x

Jonas S.

Member
Sep 21, 2016
15
7
23
38
This will probably not hit many people but it bit me and should be in the doc, at least until Octopus packages are upgraded to 15.2.14.
The Bug that hit me:
https://tracker.ceph.com/issues/51673

Fixed in 15.2.14:
CephFS: old clusters (pre-Jewel) that did not use CephFS have legacy data structures in the ceph-mon stores. These structures are not understood by Pacific monitors. With Octopus v15.2.14, the monitors have been taught to flush and trim these old structures out in preparation for an upgrade to Pacific or Quincy. For more information, see Issue 51673 <https://tracker.ceph.com/issues/51673>.

It was not easy to downgrade to Octopus but it can be done and everything is working again.

Best regards,
Jonas Stunkat
 
  • Like
Reactions: aaron and RokaKen

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
3,009
493
88
Thanks a lot for bringing this to our attention!
I updated the known issues in the upgrade guide.
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
7,870
1,507
164
15.2.14 is also available in the ceph test repo for both PVE 6 and 7
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!