VMs are not able to boot in virtualized Proxmox


New Member
Apr 4, 2023
Hi guys,
For learning purposes I just set up a virtualized Proxmox node on my Linux laptop, using virt-manager and qemu. Everything worked very well, i set up my pihole lxc etc.
But when I started to create VMs and that kind of stuff it just didn want to work.
When I want to boot the VM it always says Guest has not initilized Display yet, which should be a GPU error or something. I tried changing the GPU several times to every model avaiable.

One Problem that could cause this issue is that the CPU is shown as an EPYC CPU though I selected host-cpu in virt-manager. As those EPYC CPU's dont have any GPU built in, that its something to do with that or is it something with the machine type in QEMU?

If needed its running on Zorin OS Linux with mainline Kernel 6.4.11 on a Ryzen 7 4700U which I passed through 7 of the 8 cores as well as 14GB of 16GB of the memory.

pveversion shows:
pve-manager/8.0.4/d258a813cfa6b390 (running kernel: 6.2.16-8-pve)
I've enabled all the stuff in the XML config in virsh. Enabled VT-X or in that case AMD-SVM on the host and the Proxmox System and all that kind of stuff. Looks like virt-manager is using some kind of fallback since when I dump the XML again I see that it tries to emulate some kind of EPYC Rome with the set parameters of 7 cores.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!