[SOLVED] Vm can't create any partition

Zaregoto

New Member
Jul 11, 2021
1
0
1
Everytime I tried to install Debian or Ubuntu server in a vm (that would be my first one) everything goes well until it's time to write the partition unto the disk and create the filesystem (even with the whole disk on ext4 or ext4 +swap)

And on debian it says "The ext4 file system creation in partition #1 of SCSI3 (0,0,0) (sda) failed" (or "swap file system" if I'm trying to do ext4 +swap)
Ubuntu server tell basically the same thing

I'm on a DL380 G9, my storage disk are on snapRAID + mergers (1x4tb xfs + 2x2tb xfs)
proxmox ve 7 (but the problem was already there in 6.4) and the latest Debian or ubuntu server iso
All the vm setting are the default. I tried different SCSI controller like VirtIO SCSI (the single one too) or LSI 53C895A.

Solved: after hours of desperation, I just thought fuck it reinstalled everything and it worked for some reason.

no idea why, but it's 1am so I'm not searching

edit 2: the problem was still there because the problem was that stocking vm image behind mergerfs is too slow, so slow that it caused the problem. The solution is then to simply not use mergerfs where you stock your image
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!