unique server uid

dietmar

Proxmox Staff Member
Staff member
Apr 28, 2005
16,505
320
83
Austria
www.proxmox.com
We automatically generate an SMBIOS type 1 uuid setting when you create a VM. Not sure what
kind of unique server uid they talk about?
 

felipe

Member
Oct 28, 2013
152
1
18
yes i know. maybe i have to fill out all the settings in the SMBIOS tab
strange because they specialliy mention that proxmox/kvm does not work. but what vmware has that kvm hasnt?
see the text from their homepage:
-------------------------

Cause:

The problem is very likely caused by an unsupported virtualization platform. Officially supported is only VMware as virtualization platform. Other virtualization solutions like Virtualbox, Proxmox and KVM are unable to provide a unique Server ID that is used for licensing purposes.

Resolution:

AutoStore is not supported on these virtualized clients. Please make sure to install AutoStore on a supported host, either virtualized by VMware or a hardware based host.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,690
435
83
I assume that is just a decision of the vendor, I do not see any technical problem to get this running on KVM/Proxmox.
 

wbumiller

Proxmox Staff Member
Staff member
Jun 23, 2015
645
85
28
It would be helpful to know what mechanism they use to get such an ID, and whether they are specifically trying to detect virtualization...
ry appending `,hidden=1` to the `cpu` setting in the VM's `/etc/pve/qemu-server/$vmid.conf`?
 

Fail

New Member
Nov 16, 2018
1
1
3
39
Hi, upping this thread because i had the same problem with Nuance Autostore.
I know that it runs under virtualbox ( although not officially supported ) so i compared through dmidecode under linux and hwinfo under windows the hardware output. The difference was that virtualbox sets more default options in smbios. I thought that the license system use some combination of hardware serial and i started checking the missing one. In Virtualbox i noted that motherbaord serial number was 0.
Setting to 0 motherboard serial number in proxmox ( via gui and editing args in confgi file ) did solve the problem, the missing LICENSE ID was generated and then activated trough official channel.

in config file now i have

args: -smbios type=2,manufacturer="XXX",product="XXX",serial=0
smbios1: uuid={your-uuid},manufacturer=XXX,product=XXX,serial=0
 
  • Like
Reactions: shantanu

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!