Unble to connect spice

magikbibi

New Member
Sep 10, 2014
3
0
1
Hello everybody, i installed promox (thery good product). Here is the version :

Code:
proxmox-ve-2.6.32: 3.2-136 (running kernel: 2.6.32-32-pve)
pve-manager: 3.2-30 (running version: 3.2-30/1d095287)
pve-kernel-2.6.32-32-pve: 2.6.32-136
pve-kernel-2.6.32-29-pve: 2.6.32-126
lvm2: 2.02.98-pve4
clvm: 2.02.98-pve4
corosync-pve: 1.4.7-1
openais-pve: 1.1.4-3
libqb0: 0.11.1-2
redhat-cluster-pve: 3.2.0-2
resource-agents-pve: 3.9.2-4
fence-agents-pve: 4.0.10-1
pve-cluster: 3.0-14
qemu-server: 3.1-34
pve-firmware: 1.1-3
libpve-common-perl: 3.0-19
libpve-access-control: 3.0-15
libpve-storage-perl: 3.0-22
pve-libspice-server1: 0.12.4-3
vncterm: 1.1-8
vzctl: 4.0-1pve6
vzprocps: 2.0.11-2
vzquota: 3.1-2
pve-qemu-kvm: 2.1-5
ksm-control-daemon: 1.1-1
glusterfs-client: 3.5.2-1

My computer is under Win7 x64 (sorry ^^)

when I connect to my VM with VNC console I have 2 mouse cursors. Same when I use the console HTML5

So I wanted to try spice but without success. Here is the error I meet:

Code:
"C:\Program Files\VirtViewer\bin\remote-viewer.exe" D:\Environnement\Bureau\pqvsD6RN --debug

(remote-viewer.exe:5236): remote-viewer-WARNING **: Failed to add ui file '/usr/x86_64-w64-mingw32/sys-root/mingw/share/virt-viewer/ui/virt-viewer.xml': Failed to open file '/usr/x86_64-w64-mingw32/sys-root/mingw/share/virt-viewer/ui/virt-viewer.xml': No error
(remote-viewer.exe:5236): remote-viewer-DEBUG: Insert window 0 00000000008840A0
(remote-viewer.exe:5236): remote-viewer-DEBUG: No configuration file C:\Users\Fabien\AppData\Local\virt-viewer\settings
(remote-viewer.exe:5236): remote-viewer-DEBUG: fullscreen display 0: 0
(remote-viewer.exe:5236): remote-viewer-DEBUG: Opening display to D:\Environnement\Bureau\pqvsD6RN
(remote-viewer.exe:5236): remote-viewer-DEBUG: Guest (null) has a spice display
(remote-viewer.exe:5236): remote-viewer-DEBUG: After open connection callback fd=-1
(remote-viewer.exe:5236): remote-viewer-DEBUG: Opening connection to display at D:\Environnement\Bureau\pqvsD6RN
(remote-viewer.exe:5236): remote-viewer-DEBUG: New spice channel 00000000008FCDD0 SpiceMainChannel 0
(remote-viewer.exe:5236): remote-viewer-DEBUG: notebook show status 00000000008E3090

(remote-viewer.exe:5236): GLib-CRITICAL **: Source ID 15 was not found when attempting to remove it

(remote-viewer.exe:5236): GSpice-WARNING **: Socket I/O timed out
(remote-viewer.exe:5236): remote-viewer-DEBUG: main channel: failed to connect
(remote-viewer.exe:5236): remote-viewer-DEBUG: Disposing window 00000000008840A0

(remote-viewer.exe:5236): remote-viewer-DEBUG: Set connect info: (null),(null),(null),-1,(null),(null),(null),0


I don't have Firewall in my computer

Can anyone help me ? or do you have any suggestions?
Thank you very mush
 

symmcom

Renowned Member
Oct 28, 2012
1,084
33
68
Calgary, Canada
www.symmcom.com
I had same issue for many months on Windows 7 64bit. Never found any solution. Tried everything was suggested by community. I finally started using RDP instead.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,420
856
163
post you VM config.

> qm config VMID
 

magikbibi

New Member
Sep 10, 2014
3
0
1
My VM config (Windows 2012R2) :

Code:
root@srv-virtual:~# qm config 102
bootdisk: virtio0
cores: 2
ide2: local:iso/VMware-tools-windows-9.4.10-2068191.iso,media=cdrom,size=78528K
memory: 2048
name: srv-2012r2-ad
net0: e1000=E6:1A:AC:DA:3C:61,bridge=vmbr0
ostype: win8
smbios1: uuid=472fa347-bc4f-40c8-a103-94f5826ee848
sockets: 2
tablet: 0
vga: qxl
virtio0: VMs:102/vm-102-disk-1.qcow2,format=qcow2,size=50G

And another VM (Linut Mint) wich the same problem :

Code:
root@srv-virtual:~# qm config 103
bootdisk: virtio0
cores: 2
ide2: local:iso/linuxmint-17-cinnamon-64bit-v2.iso,media=cdrom
memory: 2048
name: mint
net0: e1000=8E:D7:39:0A:E3:E2,bridge=vmbr0
ostype: l26
smbios1: uuid=e5bbf053-90e1-4db6-aca2-ae489081d1a2
sockets: 2
vga: qxl
virtio0: VMs:103/vm-103-disk-1.qcow2,format=qcow2,size=60G

I don't think it's about VM config, as symmcom says, i think it's a compatibility problem betwenn virt-viewer and my computer OS (Win 7 x64).
 

magikbibi

New Member
Sep 10, 2014
3
0
1
I just tried with my Mint Laptop (to remote a vm with spice) and it's work fine. It's a problem with Win 7 x64
Thank you
 

tylerpitchford

New Member
Oct 21, 2014
2
0
1
I just tried with my Mint Laptop (to remote a vm with spice) and it's work fine. It's a problem with Win 7 x64
Thank you

Experiencing the same problems here. CentOS 7 VM. I can connect from my Linux desktop but not from any Windows 7, 64-bit machines. The debug output is the same as above (on both the x86 and x64 clients):

(remote-viewer.exe:3484): remote-viewer-WARNING **: Failed to add ui file '/usr/
x86_64-w64-mingw32/sys-root/mingw/share/virt-viewer/ui/virt-viewer.xml': Failed
to open file '/usr/x86_64-w64-mingw32/sys-root/mingw/share/virt-viewer/ui/virt-v
iewer.xml': No error
(remote-viewer.exe:3484): remote-viewer-DEBUG: Insert window 0 00000000008640A0
(remote-viewer.exe:3484): remote-viewer-DEBUG: fullscreen display 0: 0
(remote-viewer.exe:3484): remote-viewer-DEBUG: Opening display to download.vv
(remote-viewer.exe:3484): remote-viewer-DEBUG: Guest (null) has a spice display
(remote-viewer.exe:3484): remote-viewer-DEBUG: After open connection callback fd
=-1
(remote-viewer.exe:3484): remote-viewer-DEBUG: Opening connection to display at
download.vv
(remote-viewer.exe:3484): remote-viewer-DEBUG: New spice channel 00000000008DC22
0 SpiceMainChannel 0
(remote-viewer.exe:3484): remote-viewer-DEBUG: notebook show status 000000000089
3090


(remote-viewer.exe:3484): GLib-CRITICAL **: Source ID 15 was not found when atte
mpting to remove it


(remote-viewer.exe:3484): GSpice-WARNING **: Socket I/O timed out
(remote-viewer.exe:3484): remote-viewer-DEBUG: main channel: failed to connect
(remote-viewer.exe:3484): remote-viewer-DEBUG: Disposing window 00000000008640A0




(remote-viewer.exe:3484): remote-viewer-DEBUG: Set connect info: (null),(null),(
null),-1,(null),(null),(null),0

I'll try making a connection from a Windows 8 machine this evening.
 
Last edited:

tylerpitchford

New Member
Oct 21, 2014
2
0
1
Oddly enough, it works when connecting from a Windows 8 machine, but not a Windows 7 machine. That said, on Windows 8 there's no mouse pointer shown but if you logout and then back in the mouse pointer appears -- go figure.
 
Last edited:

ichintu

New Member
Nov 24, 2014
1
0
1
I am having this same issue tried Win 7 x64 and Win 8.1 x64


"c:\Program Files\VirtViewer\bin\remote-viewer.exe" download.vv --debug
(remote-viewer.exe:2368): remote-viewer-WARNING **: Failed to add ui file '/usr/x86_64-w64-mingw32/s
ys-root/mingw/share/virt-viewer/ui/virt-viewer.xml': Failed to open file '/usr/x86_64-w64-mingw32/sy
s-root/mingw/share/virt-viewer/ui/virt-viewer.xml': No error
(remote-viewer.exe:2368): remote-viewer-DEBUG: Insert window 0 00000000008140A0
(remote-viewer.exe:2368): remote-viewer-DEBUG: No configuration file C:\Users\chintu\AppData\Local\v
irt-viewer\settings
(remote-viewer.exe:2368): remote-viewer-DEBUG: fullscreen display 0: 0
(remote-viewer.exe:2368): remote-viewer-DEBUG: Opening display to download.vv
(remote-viewer.exe:2368): remote-viewer-DEBUG: Guest (null) has a spice display
(remote-viewer.exe:2368): remote-viewer-DEBUG: After open connection callback fd=-1
(remote-viewer.exe:2368): remote-viewer-DEBUG: Opening connection to display at download.vv
(remote-viewer.exe:2368): remote-viewer-DEBUG: New spice channel 000000000085A030 SpiceMainChannel 0


(remote-viewer.exe:2368): remote-viewer-DEBUG: notebook show status 000000000083D090


(remote-viewer.exe:2368): GLib-CRITICAL **: Source ID 15 was not found when attempting to remove it


(remote-viewer.exe:2368): GSpice-WARNING **: Socket I/O timed out
(remote-viewer.exe:2368): remote-viewer-DEBUG: main channel: failed to connect
(remote-viewer.exe:2368): remote-viewer-DEBUG: Disposing window 00000000008140A0


(remote-viewer.exe:2368): remote-viewer-DEBUG: Set connect info: (null),(null),(null),-1,(null),(nul
l),(null),0

Please let me know if you have a solution.

thank you.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!