I'm running PVE 9.2.20. In my server is an ARC A330 for my Plex VM running Windows for transcoding. Shutting down or restarting the VM for any reason causes my entire server to hang (including the IPMI if I wait long enough). Searching for an answer led me to this post: https://forum.proxmox.com/threads/i...-pci-not-ready-after-flr-or-bus-reset.130667/
Manually putting these commands in the console (these are the IDs for my GPU and the HD Audio)
allows me to safely shut down or restart the VM once, then I have to do it again if I need to shut down or reboot the VM again.
I copied the hookscript in that post, modified the IDs to match mine, copied the script to /var/lib/vz/snippets/ via sftp, did a chmod 777 on the file just to cover my bases on permissions, and finally ran qm set 104 --hookscript local:snippets/intel-dGPU-hookscript.sh to set my VM (104) to run the hookscript. Unfortunately, every time I try to start the VM I get this error:
I copied the Cmd.pm file to my system and looked at line 174 as indicated, but I don't know what I'm really looking at to try and resolve this. Can anyone help me out? Line 174 just says this:
$pid = open3($writer, $reader, $error, @$cmd) || die $!;
I'm happy to include copies of both the hookscript and the Cmd.pm file if it's helpful...
Manually putting these commands in the console (these are the IDs for my GPU and the HD Audio)
Code:
echo > /sys/bus/pci/devices/0000:67:00.0/reset_method
echo > /sys/bus/pci/devices/0000:68:00.0/reset_method
I copied the hookscript in that post, modified the IDs to match mine, copied the script to /var/lib/vz/snippets/ via sftp, did a chmod 777 on the file just to cover my bases on permissions, and finally ran qm set 104 --hookscript local:snippets/intel-dGPU-hookscript.sh to set my VM (104) to run the hookscript. Unfortunately, every time I try to start the VM I get this error:
Code:
TASK ERROR: hookscript error for 104 on pre-start: command '/var/lib/vz/snippets/intel-dGPU-hookscript.sh 104 pre-start' failed: open3: exec of /var/lib/vz/snippets/intel-dGPU-hookscript.sh 104 pre-start failed: No such file or directory at /usr/share/perl5/PVE/Cmd.pm line 174.
$pid = open3($writer, $reader, $error, @$cmd) || die $!;
I'm happy to include copies of both the hookscript and the Cmd.pm file if it's helpful...