[SOLVED] Unable to start CT using CRON


New Member
Oct 5, 2023
Hello everyone!

This is my first post here, so apologies if I get something wrong.

Here's my issue: I have a container running Folding@Home that I want to shutdown during the night to reduce noise levels.

My current cron looks like this:

0 9 * * * /usr/bin/lxc-start 5001

0 0 * * * lxc-stop 5001

No matter what I do, I cannot get the container to start, BUT it shuts down without any issue.

On the task log / journalctl I can see that the start command gets invoked, but I haven't found a way to post any possible errors to it.

Does anyone have any idea what the issue could be? The container is standalone, no external dependencies such as network shares or the like.

Hi, I've tried it as well, and it didn't work, although I didn't try it with the full path. Gonna experiment with that option.

EDIT: That worked, thanks!
The ability to run a command by only its name, without specifying path, is taking advantage of your Shell pre-set configuration. Specifically PATH variable. (man bash > search for ENVIRONMENT)
This variable can be set in multiple places (man bash > search FILES).

However, CRON has its own environment management system (man 5 crontab) and by default user environment is not loaded. So, unless you specifically define Cron variables, you should always use absolute paths to binaries, ie /usr/bin/ls

Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!