Unable to Load Web-GUI while still able to make an SSH connection

Curtains

New Member
Sep 22, 2021
3
0
1
24
Hey, I have a very basic understanding of the linux cli and I've only recently begun using proxmox.
I've looked through a few different forum posts but I'm still at a loss.

Looking for assistance/ guidance on troubleshooting my issue.

I can ssh into my proxmox server (an old laptop) but when I attempt to connect to the web gui the connection times out. A few days ago I was not having this issue.

Here is what I get when I enter the following...
systemctl status -l pve*

Bash:
● pve-lxc-syscalld.service - Proxmox VE LXC Syscall Daemon
     Loaded: loaded (/lib/systemd/system/pve-lxc-syscalld.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2021-09-21 21:48:09 EDT; 16min ago
   Main PID: 767 (pve-lxc-syscall)
      Tasks: 9 (limit: 9335)
     Memory: 1.4M
        CPU: 3ms
     CGroup: /system.slice/pve-lxc-syscalld.service
             └─767 /usr/lib/x86_64-linux-gnu/pve-lxc-syscalld/pve-lxc-syscalld --system /run/pve/lxc-syscalld.sock

Sep 21 21:48:09 laptop-server systemd[1]: Starting Proxmox VE LXC Syscall Daemon...
Sep 21 21:48:09 laptop-server systemd[1]: Started Proxmox VE LXC Syscall Daemon.

● pvestatd.service - PVE Status Daemon
     Loaded: loaded (/lib/systemd/system/pvestatd.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2021-09-21 21:48:17 EDT; 15min ago
    Process: 1032 ExecStart=/usr/bin/pvestatd start (code=exited, status=0/SUCCESS)
   Main PID: 1038 (pvestatd)
      Tasks: 1 (limit: 9335)
     Memory: 106.2M
        CPU: 4.877s
     CGroup: /system.slice/pvestatd.service
             └─1038 pvestatd

Sep 21 21:48:15 laptop-server systemd[1]: Starting PVE Status Daemon...
Sep 21 21:48:17 laptop-server pvestatd[1038]: starting server
Sep 21 21:48:17 laptop-server systemd[1]: Started PVE Status Daemon.

● pve-daily-update.timer - Daily PVE download activities
     Loaded: loaded (/lib/systemd/system/pve-daily-update.timer; enabled; vendor preset: enabled)
     Active: active (waiting) since Tue 2021-09-21 21:48:12 EDT; 16min ago
    Trigger: Tue 2021-09-21 22:25:45 EDT; 21min left
   Triggers: ● pve-daily-update.service

Sep 21 21:48:12 laptop-server systemd[1]: Started Daily PVE download activities.

● pve-firewall.service - Proxmox VE firewall
     Loaded: loaded (/lib/systemd/system/pve-firewall.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2021-09-21 21:48:17 EDT; 15min ago
    Process: 1030 ExecStartPre=/usr/bin/update-alternatives --set ebtables /usr/sbin/ebtables-legacy (code=exited, status=0/SUCCESS)
    Process: 1033 ExecStartPre=/usr/bin/update-alternatives --set iptables /usr/sbin/iptables-legacy (code=exited, status=0/SUCCESS)
    Process: 1034 ExecStartPre=/usr/bin/update-alternatives --set ip6tables /usr/sbin/ip6tables-legacy (code=exited, status=0/SUCCESS)
    Process: 1035 ExecStart=/usr/sbin/pve-firewall start (code=exited, status=0/SUCCESS)
   Main PID: 1036 (pve-firewall)
      Tasks: 1 (limit: 9335)
     Memory: 83.3M
        CPU: 4.422s
     CGroup: /system.slice/pve-firewall.service
             └─1036 pve-firewall

Sep 21 21:48:15 laptop-server systemd[1]: Starting Proxmox VE firewall...
Sep 21 21:48:17 laptop-server pve-firewall[1036]: starting server
Sep 21 21:48:17 laptop-server systemd[1]: Started Proxmox VE firewall.

● pve-cluster.service - The Proxmox VE cluster filesystem
     Loaded: loaded (/lib/systemd/system/pve-cluster.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2021-09-21 21:48:15 EDT; 15min ago
    Process: 1018 ExecStart=/usr/bin/pmxcfs (code=exited, status=0/SUCCESS)
   Main PID: 1019 (pmxcfs)
      Tasks: 7 (limit: 9335)
     Memory: 34.8M
        CPU: 758ms
     CGroup: /system.slice/pve-cluster.service
             └─1019 /usr/bin/pmxcfs

Sep 21 21:48:14 laptop-server systemd[1]: Starting The Proxmox VE cluster filesystem...
Sep 21 21:48:15 laptop-server systemd[1]: Started The Proxmox VE cluster filesystem.

● pvesr.timer - Proxmox VE replication runner
     Loaded: loaded (/lib/systemd/system/pvesr.timer; enabled; vendor preset: enabled)
     Active: active (waiting) since Tue 2021-09-21 21:48:12 EDT; 16min ago
    Trigger: Tue 2021-09-21 22:05:00 EDT; 46s left
   Triggers: ● pvesr.service

Sep 21 21:48:12 laptop-server systemd[1]: Started Proxmox VE replication runner.

● pvedaemon.service - PVE API Daemon
     Loaded: loaded (/lib/systemd/system/pvedaemon.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2021-09-21 21:48:18 EDT; 15min ago
    Process: 1031 ExecStart=/usr/bin/pvedaemon start (code=exited, status=0/SUCCESS)
   Main PID: 1061 (pvedaemon)
      Tasks: 4 (limit: 9335)
     Memory: 140.8M
        CPU: 899ms
     CGroup: /system.slice/pvedaemon.service
             ├─1061 pvedaemon
             ├─1062 pvedaemon worker
             ├─1063 pvedaemon worker
             └─1064 pvedaemon worker

Sep 21 21:48:15 laptop-server systemd[1]: Starting PVE API Daemon...
Sep 21 21:48:18 laptop-server pvedaemon[1061]: starting server
Sep 21 21:48:18 laptop-server pvedaemon[1061]: starting 3 worker(s)
Sep 21 21:48:18 laptop-server pvedaemon[1061]: worker 1062 started
Sep 21 21:48:18 laptop-server pvedaemon[1061]: worker 1063 started
Sep 21 21:48:18 laptop-server pvedaemon[1061]: worker 1064 started
Sep 21 21:48:18 laptop-server systemd[1]: Started PVE API Daemon.

● pvenetcommit.service - Commit Proxmox VE network changes
     Loaded: loaded (/lib/systemd/system/pvenetcommit.service; enabled; vendor preset: enabled)
     Active: active (exited) since Tue 2021-09-21 21:47:49 EDT; 16min ago
    Process: 670 ExecStartPre=/bin/rm -f /etc/openvswitch/conf.db (code=exited, status=0/SUCCESS)
    Process: 671 ExecStartPre=/bin/mv /etc/network/interfaces.new /etc/network/interfaces (code=exited, status=1/FAILURE)
    Process: 680 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
   Main PID: 680 (code=exited, status=0/SUCCESS)
        CPU: 4ms

Sep 21 21:48:08 laptop-server mv[671]: /bin/mv: cannot stat '/etc/network/interfaces.new': No such file or directory
Sep 21 21:47:49 laptop-server systemd[1]: Starting Commit Proxmox VE network changes...
Sep 21 21:47:49 laptop-server systemd[1]: Finished Commit Proxmox VE network changes.

● pveproxy.service - PVE API Proxy Server
     Loaded: loaded (/lib/systemd/system/pveproxy.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2021-09-21 21:48:19 EDT; 15min ago
    Process: 1066 ExecStartPre=/usr/bin/pvecm updatecerts --silent (code=exited, status=0/SUCCESS)
    Process: 1068 ExecStart=/usr/bin/pveproxy start (code=exited, status=0/SUCCESS)
   Main PID: 1070 (pveproxy)
      Tasks: 4 (limit: 9335)
     Memory: 131.1M
        CPU: 20.328s
     CGroup: /system.slice/pveproxy.service
             ├─1070 pveproxy
             ├─4005 pveproxy worker
             ├─4006 pveproxy worker
             └─4007 pveproxy worker

Sep 21 22:04:11 laptop-server pveproxy[3977]: worker exit
Sep 21 22:04:11 laptop-server pveproxy[1070]: worker 3976 finished
Sep 21 22:04:11 laptop-server pveproxy[1070]: starting 1 worker(s)
Sep 21 22:04:11 laptop-server pveproxy[1070]: worker 4006 started
Sep 21 22:04:11 laptop-server pveproxy[4005]: unable to open log file '/var/log/pveproxy/access.log' - No such file or directory
Sep 21 22:04:11 laptop-server pveproxy[4006]: unable to open log file '/var/log/pveproxy/access.log' - No such file or directory
Sep 21 22:04:11 laptop-server pveproxy[1070]: worker 3977 finished
Sep 21 22:04:11 laptop-server pveproxy[1070]: starting 1 worker(s)
Sep 21 22:04:11 laptop-server pveproxy[1070]: worker 4007 started
Sep 21 22:04:11 laptop-server pveproxy[4007]: unable to open log file '/var/log/pveproxy/access.log' - No such file or directory

● pve-guests.service - PVE guests
     Loaded: loaded (/lib/systemd/system/pve-guests.service; enabled; vendor preset: enabled)
     Active: active (exited) since Tue 2021-09-21 21:48:21 EDT; 15min ago
    Process: 1081 ExecStartPre=/usr/share/pve-manager/helpers/pve-startall-delay (code=exited, status=0/SUCCESS)
    Process: 1082 ExecStart=/usr/bin/pvesh --nooutput create /nodes/localhost/startall (code=exited, status=0/SUCCESS)
   Main PID: 1082 (code=exited, status=0/SUCCESS)
        CPU: 827ms

Sep 21 21:48:20 laptop-server systemd[1]: Starting PVE guests...
Sep 21 21:48:21 laptop-server pve-guests[1082]: <root@pam> starting task UPID:laptop-server:0000043B:00001650:614A8B65:startall::root@pam:
Sep 21 21:48:21 laptop-server pve-guests[1082]: <root@pam> end task UPID:laptop-server:0000043B:00001650:614A8B65:startall::root@pam: OK
Sep 21 21:48:21 laptop-server systemd[1]: Finished PVE guests.

● pve-storage.target - PVE Storage Target
     Loaded: loaded (/lib/systemd/system/pve-storage.target; static)
     Active: active since Tue 2021-09-21 21:48:09 EDT; 16min ago

Sep 21 21:48:09 laptop-server systemd[1]: Reached target PVE Storage Target.

● pve-ha-lrm.service - PVE Local HA Resource Manager Daemon
     Loaded: loaded (/lib/systemd/system/pve-ha-lrm.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2021-09-21 21:48:20 EDT; 15min ago
    Process: 1074 ExecStart=/usr/sbin/pve-ha-lrm start (code=exited, status=0/SUCCESS)
   Main PID: 1080 (pve-ha-lrm)
      Tasks: 1 (limit: 9335)
     Memory: 89.4M
        CPU: 653ms
     CGroup: /system.slice/pve-ha-lrm.service
             └─1080 pve-ha-lrm

Sep 21 21:48:19 laptop-server systemd[1]: Starting PVE Local HA Resource Manager Daemon...
Sep 21 21:48:20 laptop-server systemd[1]: Started PVE Local HA Resource Manager Daemon.
Sep 21 21:48:20 laptop-server pve-ha-lrm[1080]: starting server
Sep 21 21:48:20 laptop-server pve-ha-lrm[1080]: status change startup => wait_for_agent_lock

● pve-ha-crm.service - PVE Cluster HA Resource Manager Daemon
     Loaded: loaded (/lib/systemd/system/pve-ha-crm.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2021-09-21 21:48:19 EDT; 15min ago
    Process: 1065 ExecStart=/usr/sbin/pve-ha-crm start (code=exited, status=0/SUCCESS)
   Main PID: 1069 (pve-ha-crm)
      Tasks: 1 (limit: 9335)
     Memory: 89.7M
        CPU: 601ms
     CGroup: /system.slice/pve-ha-crm.service
             └─1069 pve-ha-crm

Sep 21 21:48:18 laptop-server systemd[1]: Starting PVE Cluster HA Resource Manager Daemon...
Sep 21 21:48:19 laptop-server pve-ha-crm[1069]: starting server
Sep 21 21:48:19 laptop-server pve-ha-crm[1069]: status change startup => wait_for_quorum
Sep 21 21:48:19 laptop-server systemd[1]: Started PVE Cluster HA Resource Manager Daemon.

● pvebanner.service - Proxmox VE Login Banner
     Loaded: loaded (/lib/systemd/system/pvebanner.service; enabled; vendor preset: enabled)
     Active: active (exited) since Tue 2021-09-21 21:48:00 EDT; 16min ago
    Process: 668 ExecStart=/usr/bin/pvebanner (code=exited, status=0/SUCCESS)
   Main PID: 668 (code=exited, status=0/SUCCESS)
        CPU: 205ms

Sep 21 21:47:49 laptop-server systemd[1]: Starting Proxmox VE Login Banner...
Sep 21 21:48:00 laptop-server systemd[1]: Finished Proxmox VE Login Banner.

● pvefw-logger.service - Proxmox VE firewall logger
     Loaded: loaded (/lib/systemd/system/pvefw-logger.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2021-09-21 21:47:50 EDT; 16min ago
    Process: 669 ExecStart=/usr/sbin/pvefw-logger (code=exited, status=0/SUCCESS)
   Main PID: 689 (pvefw-logger)
      Tasks: 2 (limit: 9335)
     Memory: 1.6M
        CPU: 87ms
     CGroup: /system.slice/pvefw-logger.service
             └─689 /usr/sbin/pvefw-logger

Sep 21 21:47:50 laptop-server pvefw-logger[689]: starting pvefw logger
Sep 21 21:47:49 laptop-server systemd[1]: Starting Proxmox VE firewall logger...
Sep 21 21:47:50 laptop-server systemd[1]: Started Proxmox VE firewall logger.

tail /var/log/daemon.log

Bash:
Sep 21 22:05:11 laptop-server pveproxy[1070]: worker 4160 finished

Sep 21 22:05:11 laptop-server pveproxy[1070]: starting 1 worker(s)

Sep 21 22:05:11 laptop-server pveproxy[1070]: worker 4190 started

Sep 21 22:05:11 laptop-server pveproxy[4189]: unable to open log file '/var/log/pveproxy/access.log' - No such file or directory

Sep 21 22:05:11 laptop-server pveproxy[4190]: unable to open log file '/var/log/pveproxy/access.log' - No such file or directory

Sep 21 22:05:14 laptop-server spiceproxy[4182]: worker exit

Sep 21 22:05:14 laptop-server spiceproxy[1078]: worker 4182 finished

Sep 21 22:05:14 laptop-server spiceproxy[1078]: starting 1 worker(s)

Sep 21 22:05:14 laptop-server spiceproxy[1078]: worker 4191 started

Sep 21 22:05:14 laptop-server spiceproxy[4191]: unable to open log file '/var/log/pveproxy/access.log' - No such file or directory

Let me know how else I can make this easier to assess
 
Last edited:

Curtains

New Member
Sep 22, 2021
3
0
1
24
Does it help if you restart the pveproxy service:

# systemctl restart pveproxy.service
Thanks for the reply, unfortunately I'm not experiencing any difference after the restart.
In case this info helps, everything else seems to work. I've had my main vm running all of today with no issues (thanks to qm).
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,526
1,098
164
34
Vienna
does the folder '/var/log/pveproxy' exist ?

it should belong to the 'www-data' user and group and have permissions 700
 

Mikel.P

New Member
May 14, 2021
2
0
1
32
Dear support team,

As the member Curtain, I had also faced this issue 2 days ago. In my case, it was in 2 different servers, which are our develop servers with several VM in them.

I had the same situation and the same output as Curtain in pveproxy.service. The service pveproxy.service restart didn't work for me and because of the hurry, I had to reboot both servers. After that, the access to Web GUI works and the output of service pveproxy.service status was OK.

In my case, the folder pveproxy exists and with the correct user/group and permissions:

drwx------ 2 www-data www-data 4096 Sep 24 00:00 pveproxy

Another extra detail in my case is that we are behind a proxy, but I don't think that this could be a problem, because the access to outside was working fine. The only failure was this access to Web GUI.

Could you help us please?

Thank you in advance.
 

Curtains

New Member
Sep 22, 2021
3
0
1
24
does the folder '/var/log/pveproxy' exist ?

it should belong to the 'www-data' user and group and have permissions 700
That's bizzare, no such file or directory exist that's named: '/var/log/pveproxy'
 

Mikel.P

New Member
May 14, 2021
2
0
1
32
Dear support team,

Is there any update about this issue?

Thanks,

Kind regards.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,526
1,098
164
34
Vienna
Dear support team,

Is there any update about this issue?

Thanks,

Kind regards.
from your previous message it seemed that the issue was fixed? also it does not seem to be the same as the other user. if you still have problems i would suggest that you open a new thread with more details.
 

j03man

New Member
Oct 26, 2021
3
0
1
35
I have a similar problem! I have several NICs on HP Proliant G6 server. Eveything works properly BUT when I create a new bridge using one of the available NICs the Admin GUI times out on the original administration NIC and enables it self on my new bridged NIC. So I have to use the new IP of the new bridge to log in to the mngt GUI. The origianl stays disabled until I create a third bridge and then finally I end up with 3 NICs with bridges on it and 3 possible doors to my mngt GUI.

None if the options above solves the problem.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,526
1,098
164
34
Vienna
I have a similar problem! I have several NICs on HP Proliant G6 server. Eveything works properly BUT when I create a new bridge using one of the available NICs the Admin GUI times out on the original administration NIC and enables it self on my new bridged NIC. So I have to use the new IP of the new bridge to log in to the mngt GUI. The origianl stays disabled until I create a third bridge and then finally I end up with 3 NICs with bridges on it and 3 possible doors to my mngt GUI.

None if the options above solves the problem.
this does not sound like the same problem as the original post. please open a new thread, best if it contais more debugging info/configs/logs so others can help you directly.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!