[SOLVED] Subscription key ckeck fails: "Connection error - Timeout."

bockhold

Active Member
Jan 13, 2018
26
2
43
41
Hello,

my subscription key ckeck fails with "Connection error - Timeout.". In the beginning this worked but not since 2023-08-10. The subscription is valid until 2024-07-30.

Where can I check for a more detailed error log?

Thanks!
 
Can the host ping our shop, which is used to check validity?
ping shop.proxmox.com

As the issue doesn't seem to be that the subscription is void or the like, but rather a technical error in the network, somewhere between your host and our shop.

It would be good to check, if there was a possible change to firewall or another network component at the time this started to fail.
For further help w.r.t. subscriptions please use the Proxmox Customer portal over at https://my.proxmox.com/en - for subscription activation/validity issue you can use this even if your subscription level wouldn't cover enterprise support tickets.
 
  • Like
Reactions: Stoiko Ivanov
Thanks for your answer!
Code:
$ ping shop.proxmox.com
PING shop.proxmox.com(shop.proxmox.com (2a01:7e0:0:424::2)) 56 data bytes
64 bytes from shop.proxmox.com (2a01:7e0:0:424::2): icmp_seq=1 ttl=58 time=5.61 ms
64 bytes from shop.proxmox.com (2a01:7e0:0:424::2): icmp_seq=2 ttl=58 time=5.52 ms
$ ping -4 shop.proxmox.com
PING  (79.133.36.249) 56(84) bytes of data.
64 bytes from shop.proxmox.com (79.133.36.249): icmp_seq=1 ttl=59 time=5.20 ms
64 bytes from shop.proxmox.com (79.133.36.249): icmp_seq=2 ttl=59 time=5.23 ms
ping does work but first via IPv6. Might that be a problem?
If we don't find a quick solution I will use a support ticket.
 
Ok, I found it: it's the change to Proxmox VE itself. I updated from 7 to 8 and with that the (automatic) behavior regarding IPv6 must have changed. A NIC which did not have an IPv6 address before did so now. And as the firewall did not allow such traffic, the verification of the subscription failed with a timeout.

I found it with
Bash:
$ pvesubscription get
checktime: time
key: my-key
level: c
nextduedate: 2024-07-30
productname: Proxmox VE Community Subscription 1 CPU/year
regdate: 2023-07-30 00:00:00
serverid: my-server-id
sockets: 1
status: active
url: https://www.proxmox.com/proxmox-ve/pricing

$ wget https://www.proxmox.com/proxmox-ve/pricing
# resolves to 2a01:7e0:0:424::12 and times out after that...
Thanks for helping!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!