Some volumesd do not support snapshots


New Member
Jul 31, 2023
Hello guys, I have TrueNas as a VM and i added the storage as NFS to proxmox and i installed LXC on that storage. i had auto backup as snapshot everything worked fine but i wanted to redo it so i deleted the LXC and removed the truenas storage and remounted it and tried to make another LXC now i keep getting:
INFO: starting new backup job: vzdump 108 --notes-template '{{guestname}}' --remove 0 --node dayroxy --mode snapshot --compress zstd --notification-mode auto --storage TrueNasStorage
INFO: Starting Backup of VM 108 (lxc)
INFO: Backup started at 2024-05-07 04:02:29
INFO: status = running
INFO: CT Name: Development
INFO: including mount point rootfs ('/') in backup
INFO: mode failure - some volumes do not support snapshots
INFO: trying 'suspend' mode instead
INFO: backup mode: suspend
INFO: ionice priority: 7
INFO: CT Name: Development
INFO: including mount point rootfs ('/') in backup
INFO: temporary directory is on NFS, disabling xattr and acl support, consider configuring a local tmpdir via /etc/vzdump.conf
INFO: starting first sync /proc/1858/root/ to /mnt/pve/TrueNasStorage/dump/vzdump-lxc-108-2024_05_07-04_02_29.tmp

Although it used to work and i had more than 30 backups before while having snapshot on, also if i use tmp/zv it will work but problem is i wanted as the default without using tmp/zv any idea what it could be / how to fix it?
arch: amd64
cores: 4
features: nesting=1
hostname: Development
memory: 6144
net0: name=eth0,bridge=vmbr0,firewall=1,gw=,hwaddr=BC:24:11:19:59:93,ip=,type=veth
onboot: 1
ostype: debian
rootfs: TrueNasStorage:108/vm-108-disk-0.raw,size=16G
swap: 512
tags: development
unprivileged: 1

dir: local
        path /var/lib/vz
        content iso,images,vztmpl,rootdir,backup
        shared 0

dir: hdd
        path /mnt/pve/hdd
        content iso,images,vztmpl,snippets,rootdir,backup
        is_mountpoint 1
        nodes dayroxy

nfs: TrueNasStorage
        export /mnt/Cloud/Proxmox
        path /mnt/pve/TrueNasStorage
        content vztmpl,rootdir,backup,images,iso,snippets
        prune-backups keep-all=1

Im using TrueNAS-13.0-U6.1 Core
Last edited:

snapshots are not supported on NFS storage with RAW disks:

You could change/migrate your 108 disk to a qcow2 format for snapshot support.

Hey thank you! yeah i found a way around if i change the tmp zv directory but im confused as of why it used to work and all of the sudden it stopped also how can i change from raw to qcow2 via gui if i may ask?
Thank you so much for your reply!


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!