[SOLVED][LXC] "install" from GNU coreutils: Operation not permitted


Active Member
Aug 11, 2019
I am running ArchLinux in LXC container and I just noticed something strange started happening recently. ArchLinux's AUR (Arch User Reposity) packages files make heavy use of "install" command/utility from GNU coreutils when after compilation. A day ago I went to get new updates installed and noticed the following error for all AUR packages:
install: failed to clone '<destination path>' from '<package>': Operation not permitted

To test things out I created a clean brand new container with Arch, updated it went to create a package manually and was greeted with the same error.
So something has changed in the past week or so preventing "install" from working. Has anyone run into this issue. Are there possible workarounds?

A more complete log from "makepkg":
==> Making package: yay 11.3.2-1 (Wed Mar 29 01:13:53 2023)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found yay-11.3.2.tar.gz
==> Validating source files with sha256sums...
    yay-11.3.2.tar.gz ... Passed
==> Extracting sources...
  -> Extracting yay-11.3.2.tar.gz with bsdtar
==> Starting build()...
go build -trimpath -mod=readonly -modcacherw  -ldflags '-X "main.yayVersion=11.3.2" -X "main.localePath=/usr/share/locale/" -linkmode=external' -buildmode=pie -o yay
go: downloading github.com/Jguer/votar v1.0.0
go: downloading github.com/Jguer/go-alpm/v2 v2.1.2
go: downloading github.com/Jguer/aur v1.0.1
go: downloading github.com/Morganamilo/go-pacmanconf v0.0.0-20210502114700-cff030e927a5
go: downloading github.com/Morganamilo/go-srcinfo v1.0.0
go: downloading golang.org/x/term v0.0.0-20220722155259-a9ba230a4035
go: downloading github.com/leonelquinteros/gotext v1.5.0
go: downloading github.com/adrg/strutil v0.3.0
go: downloading golang.org/x/sys v0.0.0-20220811171246-fbc7d0a398ab
go: downloading golang.org/x/text v0.3.7
==> Entering fakeroot environment...
==> Starting package()...
msgfmt po/de.po -o po/de.mo
msgfmt po/en.po -o po/en.mo
msgfmt po/es.po -o po/es.mo
msgfmt po/eu.po -o po/eu.mo
msgfmt po/fr_FR.po -o po/fr_FR.mo
msgfmt po/id.po -o po/id.mo
msgfmt po/it_IT.po -o po/it_IT.mo
msgfmt po/ja.po -o po/ja.mo
msgfmt po/ko.po -o po/ko.mo
msgfmt po/pl_PL.po -o po/pl_PL.mo
msgfmt po/pt.po -o po/pt.mo
msgfmt po/pt_BR.po -o po/pt_BR.mo
msgfmt po/ru_RU.po -o po/ru_RU.mo
msgfmt po/sv.po -o po/sv.mo
msgfmt po/tr.po -o po/tr.mo
msgfmt po/uk.po -o po/uk.mo
msgfmt po/zh_CN.po -o po/zh_CN.mo
msgfmt po/zh_TW.po -o po/zh_TW.mo
install -Dm755 yay /home/<username>/yay/pkg/yay/usr/bin/yay
install: failed to clone '/home/<username>/yay/pkg/yay/usr/bin/yay' from 'yay': Operation not permitted
make: *** [Makefile:92: install] Error 1
==> ERROR: A failure occurred in package().

install --version
install (GNU coreutils) 9.2
Copyright (C) 2023 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <https://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by David MacKenzie.

Proxmox is fully up to date, no-subscription repo
Last edited:
That was spot-on. Thank you!

I was looking in the wrong direction as I thought it was the updates in proxmox that caused this issue, but you are right, downgrading coreutils to 9.1-3 solved the issue.
  • Like
Reactions: fweber
Glad to hear it worked out! Could you please mark the thread as solved? This should be possible by editing your first post and choosing [SOLVED] (close to the title).
  • Like
Reactions: moonman


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!