[SOLVED] Single NIC with Proxmox Management on Default and VMs on VLANs


New Member
May 24, 2023
Hi, I have an USFF Dell with a single NIC. DHCP, firewalls etc are via a Unifi UDM Pro. The UDM Pro switch port connected to Proxmox is carrying all Networks. I want to be able to have Proxmox running on the default LAN but then have home assistant running of my IoT LAN (VLAN 30). I'm happily accessing Proxmox remotely. I've tried following various bits of advice but I can't seem to get it quite right and Home Assistant never seems to get an IP. I've tried installing an instance of home assistant on the default network and that gets an IP just fine. I've also tried connecting a laptop to the IoT network and that gets an IP quite happily.

The code I've tried is:

auto lo
iface lo inet loopback

auto enp1s0
iface enp1s0 inet manual

auto vmbr0
iface vmbr0 inet manual
bridge-ports enp1s0
bridge-stp off
bridge-fd 0
bridge-vlan-aware yes
bridge-vids 2-4094

auto vmbr0
iface vmbr0 inet static

Any advice on what I might need to change or any troubleshooting steps I should take please?
So turns out I had manged to mis-configure the VLAN tag in Unifi to 29. As everything else was connecting via wifi the APs were stripping the VLAN tag so it didn't matter. Trick was physically connecting a laptop to the offending port and realising that wasn't connecting either, meaning the problem was in Unifi not Proxmox.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!