[SOLVED] QEMU image not bootable


Well-Known Member
Mar 18, 2013
Hi, there!
Today had a strange situation with image restore:
1. Source server was Proxmox 3.1 (pretty old, i know), everyday backup snapshot is made on NFS.
2. Today had a plan to migrate one qemu VM to new 4.2 proxmox cluster.
3. Stopped VM (Ubuntu web server), tried to make a fresh backup copy, but with no luck.
4. Tried to start up VM, but here comes the strangest part - it shows me, that there is no bootable partitions. Had a small heart attack :)
5. Restored previous night snapshot on new cluster - on starting got the same error. Not good.
6. Added gparted live cd, booted it up. It shows "unknown partition". Luckily there is a tool called "testdisk", that helped to get back partition table.
7. After that booted up from Ubuntu server recovery console, mounted root partition and reinstalled grub. After that reboot and everything up and running.
Hopefully for other users it will help to get VM back up and running in 10 minutes. For me it took 2 hours :)
p.s. This might some kind of bug in proxmox and qemu? VM was running without restart more than 300 days.



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!