PVEPROXY zerschossen

KlausMox

New Member
Mar 4, 2021
10
0
1
45
Hallo zusammen,

ich betreibe seit ein paar Wochen einen Fujitsu RX300S7 mit Proxmox.
Es läuft soweit alles stabil und sauber, lediglich der Raidcontroller war bislang nicht eingebunden (LSI Megaraid).
Das hab ich nun versucht zu ändern. Nach erfolgloser Installation habe ich diesen nun wieder deinstallieren wollen.

Scheinbar habe ich bei allem hin und her den pveproxy zerschossen.
Gibt es eine Möglichkeit den wieder herzustellen?

Alle Maschinen und Services laufen soweit.
Ich kann per Putty auch auf das pve. Nur die GUI lässt sich nicht mehr aufrufen...:

root@pve:~# systemctl status pveproxy.service
● pveproxy.service - PVE API Proxy Server
Loaded: loaded (/lib/systemd/system/pveproxy.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2021-03-04 22:27:28 CET; 10min ago

Mar 04 22:27:28 pve systemd[1]: pveproxy.service: Service RestartSec=100ms expired, scheduling restart.
Mar 04 22:27:28 pve systemd[1]: pveproxy.service: Scheduled restart job, restart counter is at 5.
Mar 04 22:27:28 pve systemd[1]: Stopped PVE API Proxy Server.
Mar 04 22:27:28 pve systemd[1]: pveproxy.service: Start request repeated too quickly.
Mar 04 22:27:28 pve systemd[1]: pveproxy.service: Failed with result 'exit-code'.
Mar 04 22:27:28 pve systemd[1]: Failed to start PVE API Proxy Server.

Ich hoffe es ist mir noch zu helfen ;-)

LG aus BO!
 

KlausMox

New Member
Mar 4, 2021
10
0
1
45
Hey, guten Morgen!

Hier der Post:

root@pve:~# journalctl -u pveproxy
-- Logs begin at Thu 2021-03-04 19:47:46 CET, end at Fri 2021-03-05 08:17:47 CET. --
Mar 04 19:47:55 pve systemd[1]: Starting PVE API Proxy Server...
Mar 04 19:47:56 pve pveproxy[1551]: starting server
Mar 04 19:47:56 pve pveproxy[1551]: starting 3 worker(s)
Mar 04 19:47:56 pve pveproxy[1551]: worker 1552 started
Mar 04 19:47:56 pve pveproxy[1551]: worker 1553 started
Mar 04 19:47:56 pve pveproxy[1551]: worker 1554 started
Mar 04 19:47:56 pve systemd[1]: Started PVE API Proxy Server.
Mar 04 20:14:09 pve pveproxy[1553]: worker exit
Mar 04 20:14:09 pve pveproxy[1551]: worker 1553 finished
Mar 04 20:14:09 pve pveproxy[1551]: starting 1 worker(s)
Mar 04 20:14:09 pve pveproxy[1551]: worker 7204 started
Mar 04 20:21:11 pve pveproxy[1554]: worker exit
Mar 04 20:21:11 pve pveproxy[1551]: worker 1554 finished
Mar 04 20:21:11 pve pveproxy[1551]: starting 1 worker(s)
Mar 04 20:21:11 pve pveproxy[1551]: worker 8450 started
Mar 04 20:26:05 pve pveproxy[1551]: worker 1552 finished
Mar 04 20:26:05 pve pveproxy[1551]: starting 1 worker(s)
Mar 04 20:26:05 pve pveproxy[1551]: worker 9272 started
Mar 04 20:26:06 pve pveproxy[9271]: got inotify poll request in wrong process - disabling inotify
Mar 04 20:27:14 pve pveproxy[9271]: worker exit
Mar 04 20:37:39 pve pveproxy[7204]: worker exit
Mar 04 20:37:39 pve pveproxy[1551]: worker 7204 finished
Mar 04 20:37:39 pve pveproxy[1551]: starting 1 worker(s)
Mar 04 20:37:39 pve pveproxy[1551]: worker 11134 started
Mar 04 20:44:09 pve pveproxy[9272]: worker exit
Mar 04 20:44:09 pve pveproxy[1551]: worker 9272 finished
Mar 04 20:44:09 pve pveproxy[1551]: starting 1 worker(s)
Mar 04 20:44:09 pve pveproxy[1551]: worker 12268 started
Mar 04 20:47:28 pve pveproxy[8450]: worker exit
Mar 04 20:47:28 pve pveproxy[1551]: worker 8450 finished
Mar 04 20:47:28 pve pveproxy[1551]: starting 1 worker(s)
Mar 04 20:47:28 pve pveproxy[1551]: worker 12813 started
Mar 04 21:01:07 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:01:17 pve pveproxy[12813]: Can't locate URI/http.pm: /etc/perl/URI/http.pm: Permission denied at (eval 748) line 1.
Mar 04 21:01:44 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:01:48 pve pveproxy[11134]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:02:45 pve pveproxy[12268]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:02:54 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:03:21 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:03:55 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:03:59 pve pveproxy[11134]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:04:02 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:04:04 pve pveproxy[12268]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:04:28 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:04:32 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:04:49 pve pveproxy[11134]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:10:10 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:10:43 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:17:33 pve pveproxy[12268]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:17:35 pve pveproxy[12268]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:17:40 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:26:24 pve pveproxy[12268]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:34:45 pve pveproxy[11134]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:34:53 pve pveproxy[12813]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:38:00 pve pveproxy[11134]: Use of uninitialized value $wtversionraw in pattern match (m//) at /usr/share/perl5/PVE/Service/pveproxy.pm line 222.
Mar 04 21:38:06 pve systemd[1]: Stopping PVE API Proxy Server...
Mar 04 21:38:07 pve pveproxy[1551]: received signal TERM
Mar 04 21:38:07 pve pveproxy[1551]: server closing
Mar 04 21:38:07 pve pveproxy[11134]: worker exit
Mar 04 21:38:07 pve pveproxy[12813]: worker exit
Mar 04 21:38:07 pve pveproxy[12268]: worker exit

Danke schonmal für die Rückmeldung!!!
 

Hannes Laimer

Member
Staff member
Jul 27, 2020
201
21
18
22
Algund
Funktioniert pveversion -v? Verusch mal apt install --reinstall proxmox-ve, das sollte möglicherweise fehlende oder kauptte Packete neu installieren.
 

KlausMox

New Member
Mar 4, 2021
10
0
1
45
preversion -v:

root@pve:~# pveversion -v
proxmox-ve: 6.3-1 (running kernel: 5.4.101-1-pve)
pve-manager: 6.3-4 (running version: 6.3-4/0a38c56f)
pve-kernel-5.4: 6.3-6
pve-kernel-helper: 6.3-6
pve-kernel-5.4.101-1-pve: 5.4.101-1
pve-kernel-5.4.78-2-pve: 5.4.78-2
pve-kernel-5.4.73-1-pve: 5.4.73-1
ceph: 15.2.8-pve2
ceph-fuse: 15.2.8-pve2
corosync: 3.1.0-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.20-pve1
libproxmox-acme-perl: 1.0.7
libproxmox-backup-qemu0: 1.0.3-1
libpve-access-control: 6.1-3
libpve-apiclient-perl: 3.1-3
libpve-common-perl: 6.3-4
libpve-guest-common-perl: 3.1-5
libpve-http-server-perl: 3.1-1
libpve-storage-perl: 6.3-7
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.6-2
lxcfs: 4.0.6-pve1
novnc-pve: 1.1.0-1
proxmox-backup-client: 1.0.8-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.4-5
pve-cluster: 6.2-1
pve-container: 3.3-4
pve-docs: 6.3-1
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-3
pve-firmware: 3.2-2
pve-ha-manager: 3.1-1
pve-i18n: 2.2-2
pve-qemu-kvm: 5.2.0-2
pve-xtermjs: 4.7.0-3
qemu-server: 6.3-5
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 2.0.3-pve2

Installation klappt leider nicht...
 

KlausMox

New Member
Mar 4, 2021
10
0
1
45
Nach Restart sieht es schon anders aus:

root@pve:~# apt install --reinstall proxmox-ve
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 5,600 B of archives.
After this operation, 0 B of additional disk space will be used.
Err:1 http://download.proxmox.com/debian/pve buster/pve-no-subscription amd64 proxmox-ve all 6.3-1
System error resolving 'download.proxmox.com:80' - getaddrinfo (16: Device or resource busy)
E: Failed to fetch http://download.proxmox.com/debian/...ription/binary-amd64/proxmox-ve_6.3-1_all.deb System error resolving 'download.proxmox.com:80' - getaddrinfo (16: Device or resource busy)
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
root@pve:~# apt install --reinstall proxmox-ve
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 5,600 B of archives.
After this operation, 0 B of additional disk space will be used.
Err:1 http://download.proxmox.com/debian/pve buster/pve-no-subscription amd64 proxmox-ve all 6.3-1
System error resolving 'download.proxmox.com:80' - getaddrinfo (16: Device or resource busy)
E: Failed to fetch http://download.proxmox.com/debian/...ription/binary-amd64/proxmox-ve_6.3-1_all.deb System error resolving 'download.proxmox.com:80' - getaddrinfo (16: Device or resource busy)
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Was hab ich getan???
 

Hannes Laimer

Member
Staff member
Jul 27, 2020
201
21
18
22
Algund
Funktioniert rm -rf /var/lib/apt/lists/*; apt update? Das sollte den apt-cache loeschen und alles noachmal herunterladen. Kannst du z.B. www.google.de anpingen?
 
  • Like
Reactions: Stoiko Ivanov

KlausMox

New Member
Mar 4, 2021
10
0
1
45
Ne, das klappt nicht:

root@pve:~# ping -c 3 www.google.de
ping: www.google.de: System error
root@pve:~#

root@pve:~# ping -c 3 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=114 time=12.7 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=114 time=11.9 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=114 time=11.8 ms

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 5ms
rtt min/avg/max/mdev = 11.826/12.164/12.732/0.423 ms
root@pve:~#
 

KlausMox

New Member
Mar 4, 2021
10
0
1
45
root@pve:~# rm -rf /var/lib/apt/lists/*; apt update
Err:1 http://ftp.de.debian.org/debian buster InRelease
System error resolving 'ftp.de.debian.org:80' - getaddrinfo (16: Device or resource busy)
Err:2 http://security.debian.org buster/updates InRelease
System error resolving 'security.debian.org:80' - getaddrinfo (16: Device or resource busy)
Err:3 http://hwraid.le-vert.net/debian jessie InRelease
System error resolving 'hwraid.le-vert.net:80' - getaddrinfo (16: Device or resource busy)
Err:4 http://download.proxmox.com/debian/ceph-octopus buster InRelease
System error resolving 'download.proxmox.com:80' - getaddrinfo (16: Device or resource busy)
Err:5 http://ftp.de.debian.org/debian buster-updates InRelease
System error resolving 'ftp.de.debian.org:80' - getaddrinfo (16: Device or resource busy)
Err:6 http://download.proxmox.com/debian/pve buster InRelease
System error resolving 'download.proxmox.com:80' - getaddrinfo (16: Device or resource busy)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
W: Failed to fetch http://ftp.de.debian.org/debian/dists/buster/InRelease System error resolving 'ftp.de.debian.org:80' - getaddrinfo (16: Device or resource busy)
W: Failed to fetch http://ftp.de.debian.org/debian/dists/buster-updates/InRelease System error resolving 'ftp.de.debian.org:80' - getaddrinfo (16: Device or resource busy)
W: Failed to fetch http://security.debian.org/dists/buster/updates/InRelease System error resolving 'security.debian.org:80' - getaddrinfo (16: Device or resource busy)
W: Failed to fetch http://hwraid.le-vert.net/debian/dists/jessie/InRelease System error resolving 'hwraid.le-vert.net:80' - getaddrinfo (16: Device or resource busy)
W: Failed to fetch http://download.proxmox.com/debian/ceph-octopus/dists/buster/InRelease System error resolving 'download.proxmox.com:80' - getaddrinfo (16: Device or resource busy)
W: Failed to fetch http://download.proxmox.com/debian/pve/dists/buster/InRelease System error resolving 'download.proxmox.com:80' - getaddrinfo (16: Device or resource busy)
W: Some index files failed to download. They have been ignored, or old ones used instead.
 

Hannes Laimer

Member
Staff member
Jul 27, 2020
201
21
18
22
Algund
Scheint ein Problem mit dem DNS zu sein, kannst du mal nachschauen was in /etc/resolv.conf steht? Versuch nameserver 1.1.1.1 in die Datei zu schreiben.
 

KlausMox

New Member
Mar 4, 2021
10
0
1
45
root@pve:~# ping -c 3 www.google.com
ping: www.google.com: System error
root@pve:~# ping -c 3 142.250.185.99
PING 142.250.185.99 (142.250.185.99) 56(84) bytes of data.
64 bytes from 142.250.185.99: icmp_seq=1 ttl=114 time=16.8 ms
64 bytes from 142.250.185.99: icmp_seq=2 ttl=114 time=15.10 ms
64 bytes from 142.250.185.99: icmp_seq=3 ttl=114 time=16.2 ms

--- 142.250.185.99 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 4ms
rtt min/avg/max/mdev = 15.958/16.314/16.804/0.358 ms

Also per IP gehts raus, per Adresse aber nicht?
 

KlausMox

New Member
Mar 4, 2021
10
0
1
45
Ne, irgendwie geht da gar nichts. Aber die Maschine läuft ansonsten einwandfrei!
Kann man per USB Stick "überinstallieren"?
 
May 20, 2020
57
1
8
52
Wenn die Maschinen nicht zu groß sind:

Backup auf ein NAS ... dann neu installieren und das NAS einbinden und die Backups zurück spielen ...
Das dauert natürlich entsprechend, aber es funktioniert sehr gut.
 

KlausMox

New Member
Mar 4, 2021
10
0
1
45
Supi. Ein NAS hab ich im Netz. Es sind 3 Maschinen. Zwei 500 GB und eine 300 GB.
Das kann man per Putty starten?

Vielen Dank schonmal!!!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!