[SOLVED] Proxmox + Windows Server 2008 R2 + Virtio Network = Can't get DHCP IP address

effgee

Renowned Member
Jul 29, 2013
45
15
73
Hi, I have already figured out the fix for this but posting it to help anyone else.

In my network all my VM machines were getting DHCP properly except this machine Windows Server 2008 R2 with virtio network.

I installed an Intel virtual adapter and suddenly DHCP was working.

Virtio Network adapter, No DHCP
Intel Adapter, Yes DHCP

I found this article on the proxmox wiki:

https://pve.proxmox.com/wiki/Win7_Guest_DHCP_not_working_fix

And doing the registry hack worked. Now I get DHCP on the virtio adapters.
Wish this was fixed in driver but thank you for whomever made the original wiki article.

Also of note, doing the fix via GUI for the network card drivers DID NOT WORK. Registry setting ONLY worked.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!