Proxmox VE 7.0 released!

Ramalama

Active Member
Dec 26, 2020
354
44
28
32
Vielen Dank an das ganze Team
7.0 kam früher als glaub ich alle erwatet haben

Drucke euch die Daumen ✌️
 

kieselbert

New Member
Jul 6, 2021
5
0
1
38
Das ist ja mal nen geniales Timing. Ich hatte vor 2 Tagen mit der 6.4 meine ersten Schritte gemacht und bin am Thema VLAN kollosal hängen geblieben. Eben die v7 installiert und siehe da, die Probleme haben sich in Luft aufgelöst :)
 

Fischje

Active Member
Sep 25, 2014
41
0
26
Mönchengladbach/GER
Bei mir sieht es da ganz anders aus. Mein Server ist seitdem nur noch erreichbar, wenn ich dem netzwerkadapter die adresse gebe anstatt der bridges.
Warum weiss ich nicht. Ehrlich gesagt würde ich mir wünschen das hätte weiter oben gestanden in den upgrade anleitungen, wenn ich da hätte was vorbereiten müssen mit der mac-adresse oder so. jetzt ist es wieder fummelei im nachhinein.
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,320
1,075
164
South Tyrol/Italy
shop.maurer-it.com
  • Like
Reactions: Fischje

Fischje

Active Member
Sep 25, 2014
41
0
26
Mönchengladbach/GER
Mega, gut, das wars natürlich. Dummer Typo wegen "Adresse". Den hatte ich in der Tat früher schonmal.

Wäre trotzdem toll, man würde das irgendwie früher erwähnen bevor man die ksite bootet und nicht mehr dran kommt ohne kvm...
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,320
1,075
164
South Tyrol/Italy
shop.maurer-it.com
Wäre trotzdem toll, man würde das irgendwie früher erwähnen bevor man die ksite bootet und nicht mehr dran kommt ohne kvm...
Der Link, den ich vorhin gepostet habe, verweist auf eine (relativ) neue Sektion im Upgrade How-To, da wird die Thematik jetzt noch vor dem Anpassen der Repositories fürs Upgrade erwähnt, sowas wurde mit "früher erwähnen" gemeint oder?
 
  • Like
Reactions: Fischje

crmspezi

Member
Sep 5, 2019
253
19
18
41
Germany/Thueringen
Das ist ja mal nen geniales Timing. Ich hatte vor 2 Tagen mit der 6.4 meine ersten Schritte gemacht und bin am Thema VLAN kollosal hängen geblieben. Eben die v7 installiert und siehe da, die Probleme haben sich in Luft aufgelöst :)
Na da bin ich gespannt. Ich habe VLan1 getaggt Probleme. Welche Probleme sind bei Dir gelöst?
 

kieselbert

New Member
Jul 6, 2021
5
0
1
38
Na da bin ich gespannt. Ich habe VLan1 getaggt Probleme. Welche Probleme sind bei Dir gelöst?
Ein verbugter Treiber für meine 2.5G NIC an meinem Nuc. Hat dafür gesorgt das meine Bridges keinen Traffic weitergeleitet haben. Ich dachte mein DHCP Server streikt weil er meinen VMs keine IP geben will oder beim VLAN stimmt was mit den Tags nicht. Hat mich ein paar Nerven gekostet und die v7 kam mir gerade recht, alles platt gemacht, v7 installiert und alles ging sofort. Das es ein fehlerhafter Treiber war hab ich hinterher erst erfahren. --> https://forum.proxmox.com/threads/gelöst-proxmox-auf-nuc-mit-vlans-dhcp.92027/post-401025
 

crmspezi

Member
Sep 5, 2019
253
19
18
41
Germany/Thueringen
Ein verbugter Treiber für meine 2.5G NIC an meinem Nuc. Hat dafür gesorgt das meine Bridges keinen Traffic weitergeleitet haben. Ich dachte mein DHCP Server streikt weil er meinen VMs keine IP geben will oder beim VLAN stimmt was mit den Tags nicht. Hat mich ein paar Nerven gekostet und die v7 kam mir gerade recht, alles platt gemacht, v7 installiert und alles ging sofort. Das es ein fehlerhafter Treiber war hab ich hinterher erst erfahren. --> https://forum.proxmox.com/threads/gelöst-proxmox-auf-nuc-mit-vlans-dhcp.92027/post-401025
Vielen lieben Dank für die ausführliche Antwort. Das ist aber leider nicht mein Problem.
VG crmspezi
 
  • Like
Reactions: kieselbert

Sub7

Member
Jan 13, 2018
24
3
8
46
CUDA funktioniert nicht.

Host zeigt:
Code:
root@PVE:~# ls -l /dev/nvidia*
crw-rw-rw- 1 root root 195,   0 Jul 11 21:04 /dev/nvidia0
crw-rw-rw- 1 root root 195, 255 Jul 11 21:04 /dev/nvidiactl

/dev/nvidia-caps:
total 0
cr-------- 1 root root 511, 1 Jul 11 21:04 nvidia-cap1
cr--r--r-- 1 root root 511, 2 Jul 11 21:04 nvidia-cap2

Muss aber so aussehen:
Code:
crw-rw-rw- 1 root root 195, 254 Dec 22 20:51 /dev/nvidia-modeset
crw-rw-rw- 1 root root 511,   0 Dec 22 20:51 /dev/nvidia-uvm
crw-rw-rw- 1 root root 511,   1 Dec 22 20:51 /dev/nvidia-uvm-tools
crw-rw-rw- 1 root root 195,   0 Dec 22 20:51 /dev/nvidia0
crw-rw-rw- 1 root root 195, 255 Dec 22 20:51 /dev/nvidiactl

CUDA wird ohne nvidia-uvm nicht funktionieren.

Hat schon jemand eine Lösung?

edit: Hier geht's zur Lösung.
 
Last edited:

Adi M

New Member
Mar 1, 2020
13
2
3
49
Mit der neue Version habe ich ein Problem wenn ich ein Backup zurück spielen möchte. Unter Chrome sehe ich:
1626279685253.png

und komme dann nicht weiter Wenn ich es unter Opera ausführe, sehe ich:
1626279765770.png

Es spielt keine Rolle, ob ich direkt ein VM oder CT restoren möchte, oder über den Backup-Storage.

EDIT:
Es scheint noch mehrere solche Unschönheiten zu geben wie Create new CT / VM, Netzwerkeigenschaften,
Habe es dann herausgefunden: Nach Update auf 7.0 Unbedingt den Browser-Cache löschen
 
Last edited:

mox proxer

New Member
May 11, 2021
3
0
1
31
Hi Leute,
ich wollte das pve6to7 Skript ausführen bevor ich von 6.4 auf 7.0 umsteige, aber mein System findet das Skript nicht.
Code:
-bash: pve6to7: command not found
Was mache ich falsch?
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,320
1,075
164
South Tyrol/Italy
shop.maurer-it.com
Hi Leute,
ich wollte das pve6to7 Skript ausführen bevor ich von 6.4 auf 7.0 umsteige, aber mein System findet das Skript nicht.
Code:
-bash: pve6to7: command not found
Was mache ich falsch?

Du musst zuerst die letzten Updates von PVE 6.4 reinziehen, das Checker-Script ist erst nach der Veröffentlichung des 6.4 Release integriert worden.

Die pveversion sollte in etwa wie folgt aussehen:
Code:
pveversion
pve-manager/6.4-13/9f411e79 (running kernel: ....)
 

pascal

Member
Dec 21, 2015
12
3
23
40
Habe soeben mein Homelab von 6.4 auf 7.0 aktualisiert. Lief ohne Probleme durch - vielen Dank Proxmox Team!

Einzig die folgende Meldung "stört" nun bei einem apt update/upgrade:
Code:
The following packages have been kept back:
  dh-python libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib python2 python2-minimal python2.7 python2.7-minimal
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
Beispielhaft mal ein Paket angeschaut:
Code:
root@pve01:~# apt list dh-python -a
Listing... Done
dh-python/testing 4.20201102+nmu1 all [upgradable from: 3.2019030
dh-python/now 3.20190308 all [installed,upgradable to: 4.20201102+nmu1]
Meine sources:
Code:
root@pve01:~# cat /etc/apt/sources.list
 deb http://ftp.debian.org/debian bullseye main contrib
 deb http://ftp.debian.org/debian bullseye-updates main contrib
 #deb http://ftp.debian.org/debian bullseye main contrib non-free
 #deb http://ftp.debian.org/debian bullseye-updates main contrib non-free

 # PVE pve-no-subscription repository provided by proxmox.com,
 # NOT recommended for production use
 deb http://download.proxmox.com/debian/pve bullseye pve-no-subscription 

 # security updates
 deb http://security.debian.org bullseye-security main contrib
 #deb http://security.debian.org bullseye-security main contrib non-free

Ist das ein Fehler in meiner Konfiguration, dass "Testing" Pakete genommen werden?
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,320
1,075
164
South Tyrol/Italy
shop.maurer-it.com
FYI: this is the English sub-forum, so please use English here.

Python2 is EOL since start of 2020:
https://www.python.org/doc/sunset-python-2/

So Proxmox VE 6, which based Debian 10 is the last release with support for it. Proxmox VE 7.0, based on Debian 11 Bullseye only support python3 (not 100%, there's a minimal support for a few packages that could not be updated, but that's details).

Why do you have the python(2) debhelper installed? Try removing that apt remove dh-python if not required or else try to explicitly update to the newer version: apt install dh-python and see if it is more specific abouit what's holding it back.
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,320
1,075
164
South Tyrol/Italy
shop.maurer-it.com

pascal

Member
Dec 21, 2015
12
3
23
40
FYI: this is the English sub-forum, so please use English here.

Python2 is EOL since start of 2020:
https://www.python.org/doc/sunset-python-2/

So Proxmox VE 6, which based Debian 10 is the last release with support for it. Proxmox VE 7.0, based on Debian 11 Bullseye only support python3 (not 100%, there's a minimal support for a few packages that could not be updated, but that's details).

Why do you have the python(2) debhelper installed? Try removing that apt remove dh-python if not required or else try to explicitly update to the newer version: apt install dh-python and see if it is more specific abouit what's holding it back.

EDIT: Problem solved, see next post

I was able to remove dh-python so that was not required. Not sure why it was installed in the first place. Upgrading any of the other remaining "held back" packages explicitly would result in pve packages being removed.

Code:
root@pve01:~# apt install python2
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  ceph-fuse dconf-gsettings-backend dconf-service faketime fonts-font-awesome fonts-glyphicons-halflings genisoimage glib-networking glib-networking-common glib-networking-services gsettings-desktop-schemas gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly
  gstreamer1.0-x i965-va-driver intel-media-va-driver liba52-0.7.4 libaa1 libaacs0 libacl1-dev libaom0 libappconfig-perl libapt-inst2.0 libapt-pkg5.0 libass9 libattr1-dev libavc1394-0 libavcodec58 libavfilter7 libavformat58 libavutil56 libbabeltrace1 libbdplus0 libbluray2 libbs2b0 libc-dev-bin libc-devtools
  libc6-dev libcdio19 libcdparanoia0 libcephfs2 libchromaprint1 libcodec2-0.9 libcrypt-dev libdav1d4 libdconf1 libdrm-amdgpu1 libdrm-common libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libdv4 libdvdread8 libdw1 libfaketime libfdt1 libfftw3-double3 libflite1 libfuse3-3 libgd3 libgfdb0 libgfortran5
  libgl1 libgl1-mesa-dri libglapi-mesa libglusterfs-dev libglvnd0 libglx-mesa0 libglx0 libgme0 libgomp1 libgsm1 libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgudev-1.0-0 libiec61883-0 libigdgmm11 libiscsi7 libjack-jackd2-0 libjemalloc2 libjs-bootstrap libjs-extjs liblapack3 libleveldb1d liblilv-0-0
  libllvm11 libmfx1 libmp3lame0 libmpeg2-4 libmpg123-0 libmysofa1 libnorm1 libnsl-dev libopencore-amrnb0 libopencore-amrwb0 libopenjp2-7 libopenmpt0 liborc-0.4-0 libpciaccess0 libpgm-5.3-0 libpocketsphinx3 libpostproc55 libproxmox-backup-qemu0 libproxy1v5 libpve-cluster-api-perl libpve-http-server-perl
  libqrencode4 librabbitmq4 libradosstriper1 libraw1394-11 librdkafka1 libreadline7 librgw2 librubberband2 libsamplerate0 libserd-0-0 libshine3 libshout3 libsidplay1v5 libsnappy1v5 libsodium23 libsord-0-0 libsoup2.4-1 libsoxr0 libspeex1 libsphinxbase3 libspice-server1 libsratom-0-0 libsrt1.4-gnutls
  libssh-gcrypt-4 libswresample3 libswscale5 libtag1v5 libtag1v5-vanilla libtemplate-perl libtheora0 libtirpc-dev libtwolame0 libudfread0 liburing1 libv4l-0 libv4lconvert0 libva-drm2 libva-x11-2 libva2 libvdpau-va-gl1 libvdpau1 libvidstab1.1 libvisual-0.4-0 libvpx6 libvulkan1 libwavpack1 libwayland-client0
  libx264-160 libx265-192 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-randr0 libxcb-sync1 libxcb-xfixes0 libxshmfence1 libxv1 libxvidcore4 libxxf86vm1 libz3-4 libzmq5 libzvbi-common libzvbi0 linux-libc-dev manpages-dev mesa-va-drivers mesa-vdpau-drivers mesa-vulkan-drivers
  ocl-icd-libopencl1 pocketsphinx-en-us proxmox-archive-keyring proxmox-backup-client proxmox-backup-file-restore proxmox-backup-restore-image proxmox-mini-journalreader proxmox-widget-toolkit pve-docs pve-edk2-firmware pve-i18n pve-kernel-helper pve-lxc-syscalld pve-xtermjs python-ceph-argparse qrencode
  va-driver-all vdpau-driver-all zstd
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib python2-minimal python2.7 python2.7-minimal
Suggested packages:
  python2-doc python-tk python2.7-doc binutils binfmt-support
The following packages will be REMOVED:
  ceph-common libpve-guest-common-perl libpve-storage-perl libpython-stdlib proxmox-ve pve-container pve-ha-manager pve-manager pve-qemu-kvm python python-apt python-ceph python-cephfs python-debianbts python-defusedxml python-httplib2 python-ipaddr python-itsdangerous python-minimal python-prettytable
  python-pycurl python-pysimplesoap python-rados python-rbd python-rgw python-roman python-simplejson python-soappy python-support python-werkzeug python-wstools qemu-server spiceterm
The following packages will be upgraded:
  libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib python2 python2-minimal python2.7 python2.7-minimal
7 upgraded, 0 newly installed, 33 to remove and 0 not upgraded.
Need to get 3,967 kB of archives.
After this operation, 364 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

At the same time I still get the "held back" message trying to "apt upgrade".
Code:
root@pve01:~# apt upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib python2 python2-minimal python2.7 python2.7-minimal
0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.

Tried "apt clean", "apt update", "apt upgrade" with no change.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!