proxmox-tape barcode-label: irreführende Fehlermeldung bei leerem Band

mow

Member
Nov 3, 2022
206
22
18
Moin,

es gibt da ja diesen schönen Befehl, mit dem man die gesamte Autoloaderbestückung auf einen Rutsch labeln können soll.

Funktioniert leider nicht so recht mit neuen Bändern:
Code:
# proxmox-tape barcode-label --drive lto5
checking/loading media 'STB001L5'
WARN: media 'STB001L5' read error (maybe not empty - format it first)
checking/loading media 'STB002L5'
WARN: media 'STB002L5' read error (maybe not empty - format it first)
checking/loading media 'STB003L5'
WARN: media 'STB003L5' read error (maybe not empty - format it first)
checking/loading media 'STB004L5'
WARN: media 'STB004L5' read error (maybe not empty - format it first)
checking/loading media 'STB005L5'
WARN: media 'STB005L5' read error (maybe not empty - format it first)
checking/loading media 'STB006L5'
WARN: media 'STB006L5' read error (maybe not empty - format it first)
checking/loading media 'STB007L5'
WARN: media 'STB007L5' read error (maybe not empty - format it first)
checking/loading media 'STB008L5'
WARN: media 'STB008L5' read error (maybe not empty - format it first)
TASK WARNINGS: 8

Das Band ist aber sowas von empty:
Code:
# proxmox-tape status --drive lto5 --output-format json-pretty
{
  "alert-flags": "(empty)",
  "block-number": 0,
  "blocksize": 0,
  "buffer-mode": 1,
  "bytes-read": 0,
  "bytes-written": 0,
  "compression": true,
  "density": "LTO5",
  "file-number": 0,
  "manufactured": 1369785600,
  "medium-passes": 0,
  "medium-wearout": 0.0,
  "product": "Ultrium 5-SCSI",
  "revision": "Z6KW",
  "vendor": "HP",
  "volume-mounts": 1
}

Das Problem hier ist also nicht, daß das Band nicht leer ist, sondern daß es leer ist und erst formatiert werden muß.

Nach dem Formatieren
Code:
# proxmox-tape format --drive lto5
unable to read media label: read failed - Blank Check, Additional sense: End-of-data not found
format anyways
TASK OK
ist dann auch das Labeln möglich:
Code:
# proxmox-tape label --label-text STB008L5 --drive lto5
Label media 'STB008L5' (no pool assignment)
TASK OK
und das Band sieht danach so aus (nur ein Wert geändert):
Code:
  "bytes-written": 16777216,


Das ist jetzt allerdings etwas unbefriedigend, denn um die Bänder automatisch labeln zu können, muß ich sie offensichtlich erst formatieren - und zwar egal ob die komplett leer sind oder schon was drauf ist.
Das geht aber nicht automatisch. Ich muß also alle Bänder erst manuell umlagern und formatieren, damit ich sie dann automatisch labeln kann. Das kann ich dann aber nach dem Formatieren auch gleich mit machen, wenn das Band eh schon drinliegt.

Um barcode-label nicht ganz so nutzlos zu machen, wäre es daher sinnvoll, wenn man ihm sagen könnte, daß es leere(!) Bänder - also "bytes-written": 0 - doch bitte gleich automatisch formatieren soll.
 
ok, was hier offenbar passiert ist das bei einem read von einem komplett leeren tape ein fehler zurückkommt.. hab ich zwar so noch nicht gesehen, aber kommt wahrscheinlich aufs tape+drive an

der fehler:
unable to read media label: read failed - Blank Check, Additional sense: End-of-data not found
heißt das ein end-of-data marker erwartet worden ist, den gab es aber nicht

ich stimme aber zu dass es praktisch wäre gleich beim barcode-labeln auch formatieren zu können
würdest du vielleicht ein feature request hier aufmachen?: https://bugzilla.proxmox.com
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!