Proxmox network configuration for Hetzner Failover IP

danitfk

Member
Apr 20, 2015
28
1
23
Tehran
blog.gordi.ir
Hello Dear users ,

I'm trying to configure a hetzner's failover IP in Proxmox VE (4.4) with these configuration:

auto vmbr2
iface vmbr2 inet static
address <MY-IP>
netmask 255.255.255.255
pointopoint <MY-IP>
gateway <MY-IP>
bridge_ports eth0
bridge_stp off
bridge_fd 1
bridge_hello 2
bridge_maxage 12

But , Problem is I cannot use failover IP on virtual machine , because it's set on Host (Proxmox main server). I mean when I try set on VM it doesn't get connect or even When I try connect to failover ip via SSH it will connect to Host not the VM.

Is there any solution for it ?


Thanks
 
Last edited:

LnxBil

Famous Member
Feb 21, 2015
6,687
879
163
Saarland, Germany
I do not have a single failover IP (and will only have subnets), but this is what I have done for a ordinary subnet (you can failover a subnet via hetzners webinterface). I use routed mode, because I do not have to configure a lot and do not need to specify mac addresses with hetzner beforehand, so I use this config:

Code:
auto vmbr0
iface vmbr0 inet static
        address 1.2.3.1
        netmask 255.255.255.240
        bridge_ports none
        bridge_stp off
        bridge_fd 0

I have a bridge with my first subnet IP and all VMs have IPs in that subnet and on that bridge which is NOT connected to the outside world via bridge, but by routing. Maybe something similar should work for you too.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!