Proxmox Mail Gateway 7.0 released

martin

Proxmox Staff Member
Staff member
Apr 28, 2005
701
969
143
We are pleased to announce the availability of the third update in our product trilogy, the new major version 7.0 of Proxmox Mail Gateway! It is based on the latest stable release of Debian 11 ("Bullseye") with a Linux kernel 5.11 but using the newer Linux kernel 5.11, Spam Assassin 3.4.6 and PostgreSQL 13.

Here are the highlights
  • Based on Debian 11 ("Bullseye")
  • GUI enhancements, like a more detailed dashboard status panel
  • Manage the APT repositories via the GUI
  • ACME/Let's Encrypt now supports using wildcard
  • LISTEN_IP parameter
  • Improved Proxmox installer environment
  • Bug fixes and improvements
Countless bugfixes and other smaller improvements are included as well, see the full release notes.

Release notes
https://pmg.proxmox.com/wiki/index.php/Roadmap#Proxmox_Mail_Gateway_7.0

Download
https://www.proxmox.com/en/downloads
Alternate ISO download:
http://download.proxmox.com/iso

HELP & SUPPORT

Documentation

https://pmg.proxmox.com/pmg-docs

Community Forum
https://forum.proxmox.com

Source Code
https://git.proxmox.com

Bugtracker
https://bugzilla.proxmox.com

FREQUENTLY ASKED QUESTIONS

Q: Can I upgrade Proxmox Mail Gateway 6.x to 7.0?
A: Please follow the upgrade instructions on https://pmg.proxmox.com/wiki/index.php/Upgrade_from_6.x_to_7.0

Q: Can I install Proxmox Mail Gateway on top of Debian Bullseye?
A: Yes, see https://pmg.proxmox.com/pmg-docs/pmg-admin-guide.html#pmg_install_on_debian

Q: Can I install Proxmox Mail Gateway as a virtual machine on Proxmox Virtual Environment, VMware, or Hyper-V ?
A: Yes, just do the ISO install. If you install on Hyper-V as a generation 2 virtual machine, please disable secure boot.

Q: Can I install Proxmox Mail Gateway as LXC container on Proxmox Virtual Environment?
A: Yes, just download the template via the integrated template downloader.

Thanks to all the people who contributed to Proxmox Mail Gateway in this release cycle, for your feedback, testing, bug reporting and patch submitting!

__________________
Best regards,

Martin Maurer
Proxmox Mail Gateway project leader
 

kliment.toshkov

New Member
May 27, 2021
20
0
1
42
Upgrade on LXC failed, postgresql got f*** up and all databases disappeared. Also LXC for 7.0 is not found, only 6.4 is available at the moment yet.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,250
806
163
Upgrade on LXC failed, postgresql got f*** up and all databases disappeared. Also LXC for 7.0 is not found, only 6.4 is available at the moment yet.
Please provide details about your postgresql issues and your LXC config and Proxmox VE host - all this is a new thread.
 

poetry

Member
May 28, 2020
73
14
8
So if I am currently running Mail Gateway 6.4-4 and I do Configuration-Backup Now and download that file. Install on new VM with https://www.proxmox.com/en/downloads/item/proxmox-mail-gateway-7-0-iso-installer on the same IP address as old machine and upload the configuration from Mail Gateway 6.4-4 will this work? Our incoming mail gateway is standalone without any special configuration/modification other than what you can do via GUI.

I don't care about the history I just want a clean install with latest Mail Gateway with same configuration.
To me it seems like this is the cleanest way to do upgrade and avoid problems in the future with upgrading.

Will do some testing tomorrow. Thanks for the continuous hard work on this amazing product.

EDIT: just want to let you know that this works fine. Done as I said in my post and no issues.
Backup of the configuration is located /var/lib/pmg/backup/
For permanent route you can add them on /etc/network/interfaces
example post-up ip route add 192.168.2.0/24 via 192.168.2.1 dev ens192
 
Last edited:
  • Like
Reactions: Stoiko Ivanov

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,548
1,202
164
South Tyrol/Italy
shop.proxmox.com

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,548
1,202
164
South Tyrol/Italy
shop.proxmox.com
Try clear browser cache and multiple browser still the same problem.
Can you specify the actual problem here, as the linked thread had more than one and it would be good to know what you actually try now...
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,548
1,202
164
South Tyrol/Italy
shop.proxmox.com
Yeah, that's my commit and that's included in the pmg-gui package with version 2.4-2, released over three months ago for as update 6.4 and also included in PMG 7.0.

So either you meant something else or this is already fixed and available, thus I asked for a description of the problem here.
 

hata_ph

Active Member
Nov 13, 2019
605
120
43
42
Yeah, that's my commit and that's included in the pmg-gui package with version 2.4-2, released over three months ago for as update 6.4 and also included in PMG 7.0.

So either you meant something else or this is already fixed and available, thus I asked for a description of the problem here.
I have try few different PC running FF and Edge also have the same problem.
 

hata_ph

Active Member
Nov 13, 2019
605
120
43
42
Not sure it is just me but all graph show blank in latest Firefox 90.0.1. No problem with Microsoft Edge or Google Chrome.

1626704256372.png

Code:
root@pmg:~# pmgversion -V
proxmox-mailgateway: 7.0-1 (API: 7.0-6/773780b0, running kernel: 5.11.22-1-pve)
pmg-api: 7.0-6
pmg-gui: 3.0-3
pve-kernel-helper: 7.0-4
pve-kernel-5.11: 7.0-3
pve-kernel-5.11.22-1-pve: 5.11.22-2
clamav-daemon: 0.103.2+dfsg-2
libarchive-perl: 3.4.0-1
libjs-extjs: 7.0.0-1
libjs-framework7: 4.4.7-1
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.0-4
libpve-http-server-perl: 4.0-2
libxdgmime-perl: 1.0-1
lvm2: 2.03.11-2.1
pmg-docs: 7.0-2
pmg-log-tracker: 2.2.0-1
postgresql-13: 13.3-1
proxmox-mini-journalreader: 1.2-1
proxmox-spamassassin: 3.4.6-3
proxmox-widget-toolkit: 3.3-4
pve-firmware: 3.2-4
pve-xtermjs: 4.12.0-1
zfsutils-linux: 2.0.4-pve1
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,512
735
133
33
Vienna
Not sure it is just me but all graph show blank in latest Firefox 90.0.1. No problem with Microsoft Edge or Google Chrome.
please delete your browser cache
 

hata_ph

Active Member
Nov 13, 2019
605
120
43
42
Just nitpicking but the notification on top instead of at the corner is a bit annoying. Could it move back to the previous corner location?

1626845159138.png
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,548
1,202
164
South Tyrol/Italy
shop.proxmox.com

MichaelTrip

Member
Jan 5, 2017
7
1
23
35
I tried to migrate my pmg from 6 to 7 in a cluster to a lxd container but that failed. I rebuild the slave node with debian 11 but when i try to install the package proxmox-mailgateway-container i get the following error:

Bash:
root@antispam02:/etc/apt# apt install proxmox-mailgateway-container
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 exim4-config : Conflicts: postfix but 3.5.6-1+b1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,548
1,202
164
South Tyrol/Italy
shop.proxmox.com
Debian still defaults to exim as MTA, rather due to historical reasons not technical.

Try adding postfix explicitly to the packages you want to install to
Bash:
apt install proxmox-mailgateway-container postfix
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!