[SOLVED] Proxmox + Hetzner Storage Box

Kaan Karaca

Renowned Member
Jul 17, 2013
8
1
68
Hi,

I bought the BX11 Storage Box offering from Hetzner and also do have a dedicated server with Proxmox (v8.0.3) installed on it.
Network etc. works, but I stuck in adding the BX11 to my Proxmox setup.

Current status:
- A directory on BX11 at "/home/backups/myproxmox" has been created
- BX11 is configured with a sub user and "/home/backups/myproxmox" is selected as base dir

I can login via ssh
Bash:
ssh ssh://u12345-sub1@u12345.your-storagebox.de:23
u12345-sub1@u12345.your-storagebox.de's password:

Trying to add it to my Proxmox setup fails on the GUI as well as when I try to do in on the console:
I used following data:

ID: mystorgebox
Server: u12345.your-storagebox.de
Username: u12345-sub1
Password: <PW>
Share: backup
Nodes: my single node I use
Enable: yes
Content: Disk Image (additional will be added after successfull config)
Domain: empty
Subdirectory: /home/backups/myproxmox

On the Gui I get following message:
Code:
create storage failed: mount error: Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg) (500)

on the console I get this one:
Bash:
mount.cifs -o user=u12345-sub1,pass=<PW> //u12345.your-storagebox.de/backup /home
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

Kernerlog isn't really helpful either
Code:
CIFS: VFS: cifs_mount failed w/return code = -2

Trying out various combinations didn' helped either.

Am I missing something? Any help is much appreaciated.
 
Sure. This is what gets written, when I press the "Add" button
Code:
Jul 31 12:40:26 pve1 kernel: CIFS: Attempting to mount \\u12345.your-storagebox.de\backup
Jul 31 12:40:27 pve1 kernel: CIFS: VFS: cifs_mount failed w/return code = -2
 
Try repacing the share with Share: u12345-sub1 in your configuration

Also are you sure you want to mount the backup over /home ? The /home folder contains the configuration of all users with the exception of root. Maybe you want to configure an other mount point like /home/backup/mnt ?
 
Changing the share result in the same error msg.
As I'm trying to use a sub-account and have set the home for u12345-sub1 to /home/backups/myproxmox.
 
Last edited:
You are welcome! Please mark the thread as solved then :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!