Proxmox hangs after transmitting large amount of data over sshfs


New Member
Jan 17, 2023
I have an LXC container that has a bind mount to a host folder. That host folder is a mount itself to a folder on a raspi over an sshfs connection.

I am running a backup script every night that writes data to the mounted folder in the container so that it is written to the Pi. This worked previous to me upgrading to Proxmox 8 and me getting a new hard drive for the Raspi, but now it doesn't. After transmitting like 48 GB Proxmox's internet completely freezes and I get a:

task sh:14821 blocked for more than 483 seconds.
task pigz:14823 blocked from more than 483 seconds.

When I run ping I get no response. This happens when I run rsync manually as well. I have to reboot in order to fix the internet.

This is my fstab:
pi@ /mnt/pi-nextcloud-backups fuse.sshfs x-systemd.automount,_netdev,reconnect,identityfile=/root/.ssh/id_rsa,allow_other,default_permissions 0 0
Last edited:
I have an extremely similar issue. sshfs in lxc to mount shares from other lxc containers and after moving lots of data it locks up the lxc and the host requiring the host to be rebooted
Have you found a solution or alternative workaround? I'm gonna be trying nfs sharing to see if that works and if not spin up as a vm and lock it down that way
@jeefs Nope, I was never able to find a solution. I ended up just plugging my drive into my server directly and not running backups over my network.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!