[SOLVED] Proxmox boot issue


New Member
May 2, 2022
Hello everyone,

I had installed a new LSI 9207-8e a couple days ago and everything was pretty good. A number of reboots were done since the hardware install. The plan was to eventually pass it through to a VM. I had done some reading and found many saying that I should add "mpt3sas.max_queue_depth=10000" to GRUB_CMDLINE_LINUX_DEFAULT.

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINX_DEFAULT="quiet intel_iommu=on"
#GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on pcie_acs_override=downstream,multifunction video=efifb:off"
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on mpt3sas.max_queue_depth=10000 pcie_acs_override=downstream,multifunction video=efifb:off"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I ran update-grub and all seemed good. I eventually rebooted the host and was surprised when it did not come back up some minutes later. I waited about 30 minutes and then I shut down the host. Grabbed my crash cart and powered on the host. The screen output was pretty simple.


I scratched my head and grabbed my livecd and was able to get a rescue boot. So, I went back to the grub file, reversed the change, ran update-grub, rebooted and same issue. Used the rescue boot again and noticed that when the system loaded, it was using Kernel 5.15.107-2-pve. This reminded me about something I had briefly seen in the last update-grub output.

root@pve:/etc/default# update-grub
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.15.108-1-pve
Found linux image: /boot/vmlinuz-5.15.107-2-pve
Found initrd image: /boot/initrd.img-5.15.107-2-pve
Found linux image: /boot/vmlinuz-5.13.19-6-pve
Found initrd image: /boot/initrd.img-5.13.19-6-pve
Found linux image: /boot/vmlinuz-5.13.19-2-pve
Found initrd image: /boot/initrd.img-5.13.19-2-pve
Found memtest86+ image: /boot/memtest86+.bin
Found memtest86+ multiboot image: /boot/memtest86+_multiboot.bin
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...

I noticed that vmlinuz-5.15.108-1-pve was present but there was no initrd.img-5.15.108-1-pve. Feeling confident that this was part of the problem, I rebooted the host and did not use the rescue boot. Instead, I used the advanced options and selected 5.15.107-2-pve. The host happily booted.

I'm hoping that someone might be able to give me some advice on how to proceed from here. I've read that I could run "proxmox-boot-tool kernel pin 5.15.107-2-pve" to work around the problem but I would like to find out if I could actually fix it so 5.15.108-1-pve would work.

I apologize for my long post but I like to try giving as much (hopefully relevant) information as possible when asking for help. I also apologize because I'm pretty much a noob when it comes to GRUB and the Proxmox boot process.

Thank you very much for any advice and help that you can provide.
After doing a lot more research, I found this command mentioned by/to users who seemed to have a similar issue.

apt --fix-broken install

I ran this and it indicated that it found a couple packages that were not fully installed or removed.
It ran through a bunch of steps, including generating the missing initrd file and generating fresh grub configuration.
Rebooted and everything was working again.

Well, that was easy, right?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!