[SOLVED] Proxmox Backup Add usign DNS doesn't work


New Member
Jan 30, 2024
I can add my backup storage using it's public IP (I only allow my PVEs public outbound IPs and I use namespaces)
but when I try to do it using DNS it doesnt work.
Am I doing something wrong or is it by design?
if it's by design, is there a way to circumvent it?
does the name resolution work? Try dig {fqdn} on the CLI of the PVE node to see what you get returned.
Is the PBS in the same network or in another one? Can you ping the PBS? (make sure ICMP traffic is allowed)
It's over the internet, that's the reason I only allow my PVEs public outbound IPs and I use namespaces.
I don't accept pings but I can verify that name-resultion works and usign the IP instead of the name works.
What is the exact error you get when you try to connect?
If the certificate is not valid (self signed, different domain), do you provide the fingerprint of it when you set up the connection on the PVE side?
@all I was to fast.. so actually when it wasn't working it just didn't reolve the DNS yet, but when I tested it was wokring already..
I always use Cloudflare DNS while also setting my Entrys there.. so I'm not used to wait :)

is there a way to close this as resolved?
  • Like
Reactions: aaron
you can edit the first post and select the prefix next to the title :)
  • Like
Reactions: vec0


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!