Proxmox 6: WOL no more

Zamana

Well-Known Member
Dec 20, 2015
74
0
46
55
Hi!

Until 5.4 I were able to turn on a Proxmox server with the WOL Magic Pack.

After upgrading to 6 and everything else kept the same (hardware, bios, router etc), this isn't working any more.

By searching a little, I found some people talking about something related to the fact that, the current version of Debian is turning off the NIC, instead of let them in a kind of "low power" state, so that they can receive the magic packets...

I tried to put "NETDOWN=no" in /etc/default/halt, but no effect.

Does anybody know something about this?

Thanks.
Regards.
 
Last edited:
HI,
what does ethtool <ifname> report back?
 
Hi!

I know somebody would ask me this, and here is the output of ethtool eno1:

Code:
root@pve:~# ethtool eno1
Settings for eno1:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: off (auto)
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

The real problem is that the NIC and the BIOS are configured for WOL (it was working with 5.4). The question is that, after the shutdown, the NIC seems to be really powered off, as if the server had been disconnected from the power source. As the NIC isn't ON, it can't receive the magic ckets.

That seems to be the problem.
 
Hi,

I'm having a similar problem with a very common NIC :

RTL8111/8168/8411

Supports Wake-on: pumbg
Wake-on: g

Previous NIC ( same model / manufacturer ) works great with WOL and with earlier PVE 6.0 kernel version.

As I had a hardware problem, everything was changed, from NIC to motherboard and PVE was updated to current kernel version when I reinstalled the node.

WOL is no longer working on this node.

Now I can't say it's a hardware problem or anything related to the kernel.

Regards,

Ricardo Jorge
 
Hi,

I'm having a similar problem with a very common NIC :

RTL8111/8168/8411

Supports Wake-on: pumbg
Wake-on: g

Previous NIC ( same model / manufacturer ) works great with WOL and with earlier PVE 6.0 kernel version.

As I had a hardware problem, everything was changed, from NIC to motherboard and PVE was updated to current kernel version when I reinstalled the node.

WOL is no longer working on this node.

Now I can't say it's a hardware problem or anything related to the kernel.

Regards,

Ricardo Jorge

lots of problem with r8169/r8168 card.

https://serverfault.com/questions/958323/broken-wol-with-vanilla-kernel-on-debian
https://git.kernel.org/pub/scm/linu...c?id=fa6821cbf1d9724284ef0906c9a01a5fbf13a35c

Code:
This patch now:
- leaves the chip WoL settings as is (to prevent issue 1)
- keeps the behavior to not wakeup-enable the device initially
  (to prevent issue 2)
- In addition we report WoL as being disabled in get_wol, matching
  that device isn't wakeup-enabled. If systemd is told to enable WoL,
  it will therefore detect that it has to do something and will
  call set_wol.

try to force with ethtools to activate wol before shutin download the pc to see if it works.
 
https://www.realtek.com/en/componen...0-1000m-gigabit-ethernet-pci-express-software

maybe try to use the R8168 if you use the =R8169

https://packages.debian.org/buster/r8168-dkms

some reading at the end of the page :

https://wiki.archlinux.org/index.php/Wake-on-LAN

some roads to explore ... ( i was right for the killer network card with the als driver ... )
Code:
or some newer Atheros-based NICs (such as Atheros AR8161 and Killer E2500), WOL support has been disabled in the mainline alx module due to a bug causing unintentional wake-up (see this patch discussion). A patch can be applied (or installed as a dkms module) which both restores WOL support and fixes the underlying bug, as outlined in this thread.
 
Hi,

I'm going to test the options presented but it will take a week as I can only stop this node on weekends.

Maybe I can change NIC with another brand / model.

Previous NIC ( same model / manufacturer / chipset ) works great with WOL.

The kernel version and motherboard were also different.

Thank you,

Ricardo Jorge
 
Hi,

Here I have these cards ( ASUS motherboard ) :

06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

One comes with motherboard ( bundled ).

None of them can WOL now but using previous motherboard / NIC cards I can use WOL.

And "YES" BIOS is set to WOL now and before.

Kernel module is "r8169"

Previous NICs ( Gigabyte motherboard ) :

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

Regards,

Ricardo Jorge
 
https://www.realtek.com/en/componen...0-1000m-gigabit-ethernet-pci-express-software

maybe try to use the R8168 if you use the =R8169

https://packages.debian.org/buster/r8168-dkms

some reading at the end of the page :

https://wiki.archlinux.org/index.php/Wake-on-LAN

some roads to explore ... ( i was right for the killer network card with the als driver ... )
Code:
or some newer Atheros-based NICs (such as Atheros AR8161 and Killer E2500), WOL support has been disabled in the mainline alx module due to a bug causing unintentional wake-up (see this patch discussion). A patch can be applied (or installed as a dkms module) which both restores WOL support and fixes the underlying bug, as outlined in this thread.

Hi!

I did all the procedures and ended with this:

root@pmx:/etc/modprobe.d# modprobe r8168
modprobe: ERROR: could not insert 'r8168': Exec format error

So I "unblacklisted" the r8169 and now my system is accessible again, but no WOL.

Thanks.
Regards.
 
Surprisingly, this NIC is now fully supported in FreeBSD. WOL is working with it.
 
Not on server mainboards.

i NEVER saw them on a server grade hardware.
Ok. You are right.

In my case it's a consumer board, but it behaves very well as a data NAS backup for my main server, which uses a SuperMicro board (which is a "prosumer", I supposed).
 
Hi,

@tom Yes its not a server grade motherboard but even so, there's a lot of motherboard manufacturer using it.

It worked very well ( with WOL ) before !

Regards,

Ricardo Jorge
 
Last edited:
Hi,

Today is a national holiday and I managed to go to the remote site and test WOL again and now its working as expected.

I'm running the latest PVE kernel available ( Linux pve-03 5.0.21-5-pve #1 SMP PVE 5.0.21-10 ).

Mobo is a ASUS PRIME B450M.

BIOS version: 1820 / date: 09/12/2019

NICs :

06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

Both work with WOL.

I hope this helps someone else.

Regards,

Ricardo Jorge
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!