[SOLVED] Processor compatibility mode

franko5

New Member
Feb 2, 2021
13
0
1
51
Hello,
I'm using proxmox 6.4.13 with Ubuntu 18.04 as VM, Tableau server is installed there.
It all worked fine, but the latest upgrade of Tableau is not successful with message:
To successfully install or update Tableau on a VM, make sure that processor compatibility mode is turned off.

Further explanation on Tableau support is saying:
...all nodes shall have CPUs that support SSE4.2 and POPCNT instruction sets

I don't find in proxmox documentation how to configure CPU setting with "processor compatibility mode off".
The CPU's for this VM are default - kvm64.

Proxmox CPU Model name: AMD Ryzen 9 3900 12-Core Processor
Thanks in advance.
 

avw

Active Member
May 31, 2020
967
160
43
kvm64 is very limited and has no SSE4.2 or POPCNT support. Try using host as the CPU type for the VM. Or do you need live migration to other CPU types in a cluster?
 
  • Like
Reactions: franko5

franko5

New Member
Feb 2, 2021
13
0
1
51
Hi, thanks a lot for your answer and you nailed to the point!

Just checked with host as the CPU type on a test instance and it runs smooth as it should.
Seems like this is solving my problem (shall complete that with the live system, but this obstacle has gone).
No, Tableau is not in the cluster, one server only, and this shall be ok.

All the best.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!