Probleme mit dem Herunterfahren von Win 10 VM

rainer042

New Member
Dec 3, 2019
6
0
1
119
Hallo,

ich habe proxmox 6.1-3 installiert und testweise eine Windoes10 VM eingerichtet und auf einen aktuellen Patchstand gebracht. Zudem habe ich den guest-agent installiert und in proxmox auch aktiviert. Ein qm agent <vm-id> ping klappt ohne Fehler auf dem Node auf dem die VM läuft.

Das Problem ist das Herunterfahren von Windows10 oder auch ein reboot über das Windows-Menü. Beides hängt > 5min. Beim Herunterfahren wird der "Bildschirm" nach wenigen Sekunden schwarz, dann passiert 5 Minuten lang nichts sichtbares, der Bildschirm bleibt schwarz, aber die CPU geht in dieser Zeit auch gerne mal auf 100%. Nach den 5 Minuten habe ich ein hartes "Stop" der VM gemacht. Das ist natürlich nicht der gewünschte Weg.

Ich hatte gelesen das es dieses Problem gibt, aber auch das es verschwindet, wenn man den guest-agent verwendet. Bei mit hat das leider nicht geholfen. Gibts noch andere Tips zur Lösung des Problems.... ?
 

rainer042

New Member
Dec 3, 2019
6
0
1
119
Ja genau die Wiki-Seite hatte ich als Anleitung verwendet. Allerdings musste ich die Reihenfolge ändern: Zuerst den guest-agent installieren und aktivieren und dann das PCI-Simple-Communications-Device mit dem vioserial Treiber versorgen. Ich hatte ursprünglich die stable version virtio-win-0.1.171.iso verwendet, habe aber eben auf die "latest"-Version (0.1.173) gewechselt und den vioserial Treiber upgedatet als auch den guest-agent noch einmal drüber installiert. Scheint aber keinen Effekt gehabt zu haben.

Einmal hatte ich übrigens einen erfolgreichen Shutdown allerdings erst nach 4:50min. Aber für eine VM, die nichts tut ist auch das ja doch etwas zu lang.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
14,040
485
103
Allerdings musste ich die Reihenfolge ändern: Zuerst den guest-agent installieren und aktivieren und dann das PCI-Simple-Communications-Device mit dem vioserial Treiber versorgen.
da liegt wohl der fehler, die anleitung ist schon richtig. nochmal den akuellen guest-agent von den 0.173 ISO installieren, ev. hilft das.
 

rainer042

New Member
Dec 3, 2019
6
0
1
119
Das hat leider nicht geholfen. Ich mache die Win10-Test-Maschine nochmal von vorne neu und nehme gleich die latest-treiber. Ich sag Bescheid, obs dann klappt.....
 

rainer042

New Member
Dec 3, 2019
6
0
1
119
Ich habe jetzt Win10 nocheinmal ganz neu installiert und upgedated. Mein Problem war das ich nicht zuerst in Proxmox bei den "Options" der Windows-VM den Guest-Agent aktiviert hatte, sondern dachte erst den Treiber installieren zu müssen. Daher gabs bei mir das Simple-PCI-Device nicht. Das habe ich jetzt kapiert und dann konnte ich den Treiber auch installieren und danach den Guest-Agent.

Mit dieser Installation (nach einem Reboot) dauert das Herunterfahren dann noch 3 Minuten. Ist das der erwartete Wert?

Man kann damit leben, aber ein nichts tuendes Win10 fährt normalerweise in einer halben Minute herunter, in sofern sind 3min immer noch recht lang.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!