Poor zfs read(suspected) performance, dlna streaming unusable


New Member
May 4, 2019
Dear all,

Sorry for an ambiguous title and thread as i have just put up an itx machine to try on the proxmox platform, was aniticipating a great upgrade from my old HP microserver Gen7 (ESXi) to the proxmox LXC container world. but resulting in a confused and disappointing week due to my lack of knowledge in all these new technologies (proxmox, lxc, zfs....)

i was happy setting up the environment as my media server and a couple of home hosted services, and finding the light weight lxc fun and enjoyable, i'm ending up finding my platform performing badly and not even usable on the most basic streaming. my platform hardware:

CPU: Intel G5400
OS disk: nvme M.2 128G (ext4)
media disks: 2 x WD blue 4TB (zfs raid1/mirror)

i have a couple lxc running now and used bind mount point to mount my zfs media drive to the containers for media access, i have found that i can SAMBA transfer to my laptop in normal speed (11-12MB/90-100Mb) or rsync from "media disks (zfs)" > "OS disk (ext4)" at around (170MB/s). but when i'm trying to stream videos, it just buffers of shows broken frames in an unusable manner. Even putting the jellyfin transcoding away, just by using DLNA, i found that my network interface only runs at about 1-2Mb and video also unusble. totally no idea why and maybe my zfs pool is poor in performance? (but at least samba/rsync can run quicker)

(tried both plex and jellyfin, was on plex and unusable so tried to switch to jellyfin)

below is my log from jellyfin and my rsync:

my pveperf:
root@pve:~# pveperf
CPU BOGOMIPS: 29568.00
HD SIZE: 28.91 GB (/dev/mapper/pve-root)
DNS EXT: 48.18 ms
DNS INT: 136.61 ms (kservel.invalid)

root@pve:~# pveperf /WD_4T/
CPU BOGOMIPS: 29568.00
HD SIZE: 1978.41 GB (WD_4T)
DNS EXT: 113.61 ms
DNS INT: 241.78 ms (kservel.invalid)

I'm not sure about if the DNS resolve time is a factor, i'm using my mikrotik router as the local dns and i totally don't understand why the resolve time is such slow here, and what does the DNS INT mean cuz i dont run a local domain.

If any of you are experience on such symptom, please give me a hand. i'm totally clueless now.
Thank you!!

i have an instance of Nextcloud installed, and just tried to download a movie file from my drive, the download didnt really proceed. and i have just checked on the PVE portal and found a lot of IO delay. why is this happening to some of the applications and some are not affected? why is rsync/cp/dd able to run on the host/containers normally but not the applications?

Is there anyone who has some hint or some idea on my problem? does it help if i add a cache drive for the zfs? i'm not quite sure about it as i dont know how a cache drive could help in reading performance?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!