[PARTIALLY SOLVED] Boot failed after clean Proxmox installation


New Member
Oct 19, 2023
Hi to all fans of Proxmox!

I am using Proxmox for a while for my homelab.
I recently get an old but powerfull laptop Elitebook 8570w with 32GB RAM and 1 SSD 512GB SATA
Installation from USB stick of Proxmox 7.4 or 8.0 works fine but boot loader seems not well configured as the laptop refuse to boot after installation process: "missing operating system"
I have successfully install windows 10 and Debian 12.0 on it, without any boot error.
BIOS is configured as legacy boot, and secure boot is disactivated.
Since this is a boot error, I don't know if I can get some log...

Any help will be mostly appreciate!
Thanks to all

how did you configure your boot disk? (E.g. what filesystem etc.)

BIOS is configured as legacy boot, and secure boot is disactivated.
Did you try booting/installing in UEFI mode? (With deactivated Secure Boot, of course)

Also, can you try opening the boot menu (either in the UEFI directly or by pressing some key on boot, often F2 or F11) and see if Proxmox VE appears there?
Thank you for your quick answer.
I have configured my USB stick with Rufus in dd mode, and try another smart tool as well: https://www.ventoy.net/en/index.html
in both ways, I have installed Win10 and Debian 12 successfully, and was able able to boot from SSD to run OS properly
in both ways, I have successfully boot, and run Proxmox installation process and use default settings, with a successful installation message., but when it comes to boot on the SSD drive, I get the "missing operating system" message.

I tried BIOS settings in legacy mode and hybride UEFI mode. I am able to see USB stick when it is plugged, or internal hard drive, when I use F2 but when I select SSD drive after Proxmox installation process, I always get the missing operating system message.
I feel there is sometthing wrong at the installation step of the boot loader on SSD. partition pb ? Grub pb?

I have booted with a live ubuntu and get this screenshot of /sda.

Best regards,

After many different retries (change SSD, older versions...) I finally use the "Rescue Boot" from USB key (https://pve.proxmox.com/pve-docs/chapter-pve-installation.html#install_minimal_requirements)
I am now able to boot from USB key to local SSD with Proxmox VE 8.0.2, but need a manual step at reboot.
Is there another way to correctly install Boot loader on disk ?
Thank you for your help :))


  • IMG_0069.jpg
    348.4 KB · Views: 3
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!