OVS MTU help

Discussion in 'Proxmox VE: Networking and Firewall' started by Blue)(Fusion, Jun 20, 2018.

  1. Blue)(Fusion

    Blue)(Fusion New Member

    Joined:
    Jun 20, 2018
    Messages:
    2
    Likes Received:
    0
    Hello all, first time poster here.


    I just got Gluster going on my network and am setting up a VLAN specific to Gluster storage traffic. Gluster is not hosting VM images, but VMs are accessing the Gluster data directly via the GlusterFS FUSE driver.


    With that said, I have 3x bonded 10Gbit, OVS, VLANs, and after reading the documents regarding OVS, I'm confused on exactly what I do to change the MTU on only a specific VLAN - if that is at all possible with OVS.

    The VLAN that needs MTU 9000 is 4 on the bond.

    Below is my /etc/network/interfaces:
    Code:
    auto lo
    iface lo inet loopback
    
    iface enp6s0 inet manual
    
    auto eno1
    iface eno1 inet static
            address  10.1.1.10
            netmask  255.255.255.0
            gateway  10.1.1.1
    
    iface eno3 inet manual
    
    iface eno4 inet manual
    
    iface enp5s0 inet manual
    
    iface eno2 inet manual
    
    iface enp6s0d1 inet manual
    
    allow-vmbr0 bond0
    iface bond0 inet manual
            ovs_bonds enp5s0 enp6s0 enp6s0d1
            ovs_type OVSBond
            ovs_bridge vmbr0
            ovs_options lacp=active bond_mode=balance-tcp
    
    auto vmbr0
    iface vmbr0 inet manual
            ovs_type OVSBridge
            ovs_ports bond0
     
  2. Klaus Steinberger

    Proxmox VE Subscriber

    Joined:
    Jan 16, 2018
    Messages:
    142
    Likes Received:
    19
    You have to set the jumbo frames for the underlying bond0. Due to some deficiencies of the debian network setup, you have to do it with pre-up commands:

    in the iface bondo:
    pre-up ( ip link set mtu 9000 ... && ip link set mtu 9000 ............ )
    mtu 9000

    then you have to set the MTU of course inside the VM's accessing VLAN 4
     
  3. Blue)(Fusion

    Blue)(Fusion New Member

    Joined:
    Jun 20, 2018
    Messages:
    2
    Likes Received:
    0
    Thank you Klaus. That worked perfectly.
     
  4. spirit

    spirit Well-Known Member
    Proxmox VE Subscriber

    Joined:
    Apr 2, 2010
    Messages:
    3,113
    Likes Received:
    99
    proxmox have since a long time a script to setup mtu on manual interface.
    debian have fixed it in stretch.

    so you can simply setup "mtu xxxx" in the manual interface.
     
  5. DerDanilo

    DerDanilo Member

    Joined:
    Jan 21, 2017
    Messages:
    206
    Likes Received:
    15
    Does the MTU have to be defined for a Linux bridge also that does not reference any nic (ip forwarding) and will be used for vms without setting "vlan aware"?

    Code:
    auto eno1.4000
    iface eno1.4000 inet static
          vlan-raw-device eno1
          mtu 1400
    
    Then create a Linux bridge and specify this vlan interface as uplink. Correct?

    Code:
    auto vmbr4000
    iface vmbr4000 inet static
           address 192.168.100.1
           netmask 255.255.255.0
           bridge_ports eno1.4000
           bridge_stp off
           bridge_fd 0
           mtu 1400
    #PVE-LAN1
    
    Then connect a VM NIC to this interface and set the MTU to 1400 in VM network config.

    Code:
    auto eno1
    iface eno1 inet static
           address 192.168.100.101
           netmask 255.255.255.0
           mtu 1400
    #PVE-LAN1
    
    This way direct communication between host and vms should also be possible right?
    This might also be usable to split a PVE cluster across different DCs and connect them via a vswitch vlan network.
     
    #5 DerDanilo, Jul 12, 2018
    Last edited: Jul 12, 2018
  6. DerDanilo

    DerDanilo Member

    Joined:
    Jan 21, 2017
    Messages:
    206
    Likes Received:
    15
    Anybody knows?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice