[SOLVED] No space left on /var

Por12

New Member
Mar 6, 2023
28
2
3
I'm doing a test run using docker in an unpriviledged lxc (I know, and it will eventually be moved to my production VM). All is working fine and I have a few images (portainer, traefik), but when I try to deploy something larger (e.g. paperless) I'm finding an error that there is no space left on device despite having more than enough.

Error code: write /var/lib/docker/tmp/GetImageBlob1898286929: no space left on device

However, if I run df -h:

Code:
root@docker-internal:~# df -h
Filesystem                          Size  Used Avail Use% Mounted on
/dev/loop0                          3.9G  2.3G  1.4G  62% /
rpool/ROOT/pve-1                    458G   97G  362G  22% /docker
192.168.88.253:/mnt/user/paperless   26T  5.7T   20T  23% /paperless-storage
none                                492K  4.0K  488K   1% /dev
udev                                 32G     0   32G   0% /dev/tty
tmpfs                                32G     0   32G   0% /dev/shm
tmpfs                                13G  260K   13G   1% /run
tmpfs                               5.0M     0  5.0M   0% /run/lock
fuse-overlayfs                      3.9G  2.3G  1.4G  62% /var/lib/docker/fuse-overlayfs/720a17a4b13944fff06c081d03ed9c97fdd0f4664bdad0b164dcd99135ef1bb2/merged
fuse-overlayfs                      3.9G  2.3G  1.4G  62% /var/lib/docker/fuse-overlayfs/56bebdef47d2eaf406c6ba236af1a06c08ef373ba42be0f5054010c6bb25b8a2/merged

This is the actual space used on /var
Code:
root@docker-internal:/var# du -h -d1 -x /var
12K     /var/tmp
1.1G    /var/lib
748K    /var/spool
344K    /var/backups
237M    /var/cache
4.0K    /var/mail
19M     /var/log
4.0K    /var/data
4.0K    /var/opt
4.0K    /var/local
1.3G    /var

This is my lxc conf:

Code:
arch: amd64
cores: 2
features: fuse=1,keyctl=1,nesting=1
hostname: docker-internal
memory: 4096
mp0: /virtualization_hosts/docker_data,mp=/docker
mp1: /mnt/pve/paperless,mp=/paperless-storage,replicate=0
net0: name=eth0,bridge=vmbr0,hwaddr=32:D2:40:13:7C:16,ip=dhcp,type=veth
onboot: 1
ostype: debian
rootfs: local:501/vm-501-disk-0.raw,size=4G
swap: 512
tags: proxmox-helper-scripts
unprivileged: 1
lxc.idmap: u 0 0 1
lxc.idmap: u 1 100000 65535
lxc.idmap: g 0 0 1
lxc.idmap: g 1 100000 65535

Any ideas?
 
I solved it resizing the root partition. I thought that having 62% used was enough.

Thanks!
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!