[SOLVED] No network on server unless i ifdown / ifup vmbr0

CLE

New Member
Jan 3, 2020
12
0
1
31
@CLE : ok networking is enabled. I'm going to test your config today.

also, could you replace:

allow-hotplug eno1

by

iface eno1 inet manual

?
Replacing this line seems to have done the trick?!

I've rebooted the server and the server as well as my VM and Container do have networking without a manual intervention!

@spirit thank you very much - if you need anything from me to further test this, let me know! For now i just have to remember to not touch the networking configuration from the GUI, right?

Everyone else chiming in (@jrshaw , @Homercles , @syfy323 ) Thank you as well!
 

syfy323

Member
Nov 16, 2019
77
5
8
26
Replacing this line seems to have done the trick?!

I've rebooted the server and the server as well as my VM and Container do have networking without a manual intervention!

@spirit thank you very much - if you need anything from me to further test this, let me know! For now i just have to remember to not touch the networking configuration from the GUI, right?

Everyone else chiming in (@jrshaw , @Homercles , @syfy323 ) Thank you as well!
Are you sure your connection lasts more than an hour?
Using the latest kernel causes a lot of issues with OVS an Proxmox for me (where CentOS and Debian stock work perfectly fine).
 

spirit

Famous Member
Apr 2, 2010
3,946
214
83
www.odiso.com
also, normally, the correct config should be only:

allow-vmbr0 eno1

without any "auto eno1", or "allow-hotplug eno1".

This is because it's racing between ovs init script, and ifupdown init script.

I'm pretty sure that proxmox gui is doing it fine, but I need to verify that.
 

CLE

New Member
Jan 3, 2020
12
0
1
31
Was the "allow-hotplug eno1" setup by gui ?
or maybe by the proxmox installer cd iso ?
The Server has been set up with a bare Debian (due to software RAID) and Proxmox after that according to the Wiki entry.

I‘m actually not sure if the entry was a leftover from the default install or if that was set by Proxmox.


Are you sure your connection lasts more than an hour?
Using the latest kernel causes a lot of issues with OVS an Proxmox for me (where CentOS and Debian stock work perfectly fine).
I‘m not yet sure about that - server is powered down at the moment but i‘ll try and let you know!
 

spirit

Famous Member
Apr 2, 2010
3,946
214
83
www.odiso.com
The Server has been set up with a bare Debian (due to software RAID) and Proxmox after that according to the Wiki entry.
I‘m actually not sure if the entry was a leftover from the default install or if that was set by Proxmox.
mmm,ok. I'll try to check if gui&&api could be improve to remove allow-hotplug when ovs is used
 

Homercles

Member
Jun 19, 2016
2
0
6
38
Systemctl status networking ? (I have see some case where service was not enabled After ifupdown2 install )
You are right! systemctl status networking was not enable and not running. I went ahead and just enabled the service and started it, I will try to reboot the server later when I have physical access to it.

Thank you sir!
 

CLE

New Member
Jan 3, 2020
12
0
1
31
Awesome, thank you @spirit !

Are you sure your connection lasts more than an hour?
Using the latest kernel causes a lot of issues with OVS an Proxmox for me (where CentOS and Debian stock work perfectly fine).
Server is up for around 2 hours now, networking still is fine (for VM/Containers as well as the host).

Output of uname -a

Linux servername 5.3.13-1-pve #1 SMP PVE 5.3.13-1 (Thu, 05 Dec 2019 07:18:14 +0100) x86_64 GNU/Linux
@syfy323: if you want to know something else about my setup (like package versions and such) just let me know the commands to run!
 

syfy323

Member
Nov 16, 2019
77
5
8
26
@syfy323: if you want to know something else about my setup (like package versions and such) just let me know the commands to run!
Thank you for the feedback. Did you enable the firewall option for your VM network interface (right there were you can set the hwaddr)?
I was only able to reproduce this when the firewall option is not enabled.
 

pkuwik

New Member
Jan 25, 2020
3
0
1
44
Just adding to the discussion though a different thread might be more appropriate.
I was having to issue the 'ifup vmbr0' command following each reboot to bring up the network on one of my 3 servers. All 3 servers are running a recent PVE kernel - SMP PVE 5.3.13-1 - and openvswitch-common/switch v2.10 with OVS bonds.
On the one server where I need to bring up the bridge following each reboot, I has installed ifupdown2 at the time when I was using the Linux bonds. When I installed the OVS bridge and bonds, I all of a sudden had the no-networking issue following reboot.
The solution was to uninstall the ifupdown2 package, reinstall the ifupdown package, and networking started coming up automatically following a reboot.
 

spirit

Famous Member
Apr 2, 2010
3,946
214
83
www.odiso.com
Just adding to the discussion though a different thread might be more appropriate.
I was having to issue the 'ifup vmbr0' command following each reboot to bring up the network on one of my 3 servers. All 3 servers are running a recent PVE kernel - SMP PVE 5.3.13-1 - and openvswitch-common/switch v2.10 with OVS bonds.
On the one server where I need to bring up the bridge following each reboot, I has installed ifupdown2 at the time when I was using the Linux bonds. When I installed the OVS bridge and bonds, I all of a sudden had the no-networking issue following reboot.
The solution was to uninstall the ifupdown2 package, reinstall the ifupdown package, and networking started coming up automatically following a reboot.
please provide your /etc/network/interfaces.
 

pkuwik

New Member
Jan 25, 2020
3
0
1
44
Here it is as requested:

Code:
allow-vmbr0 bond0
iface bond0 inet manual
    ovs_bonds eno1 eno2 eno3 eno4
    ovs_type OVSBond
    ovs_bridge vmbr0
    ovs_options bond_mode=balance-tcp lacp=active

auto lo
iface lo inet loopback

iface eno3 inet manual

iface eno1 inet manual

iface eno2 inet manual

iface eno4 inet manual

allow-ovs vmbr0
iface vmbr0 inet static
    address  192.168.1.20
    netmask  24
    gateway  192.168.1.1
    ovs_type OVSBridge
    ovs_ports bond0
 

spirit

Famous Member
Apr 2, 2010
3,946
214
83
www.odiso.com
@pkuwik

thanks. I can reproduce with ifupdown2 2.0 from pvetest repo, but not ifupdown2 1.2.8.

(ovs bridge+interfaces are created, but are down).

could you tell me what is your ifupdown2 version ? (dpkg -l|grep ifupdown2)
 

pkuwik

New Member
Jan 25, 2020
3
0
1
44
@spirit I uninstalled the ifupdown2 to get my OVS working again, so can not tell you what version it was exactly, but I am using the pvetest repo, and not the enterprise one
 

spirit

Famous Member
Apr 2, 2010
3,946
214
83
www.odiso.com
@spirit I uninstalled the ifupdown2 to get my OVS working again, so can not tell you what version it was exactly, but I am using the pvetest repo, and not the enterprise one
ok thanks. it's indeed ifupdown 2.0 in pvetest. I have found the bug (introduced in ifupdown2 2.0, it was working fine in 1.28).
I have send a patch, it should be fixed soon in pvetest repo.

Thanks for reporting !
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
14,110
509
133
  • Like
Reactions: pkuwik

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!