[SOLVED] No network access after fresh install


New Member
Apr 21, 2023
No one of solved posts related with this question has helped me.

I have installed Proxmox with correct network ip, gateway for my network but no network access after install.

ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master vmbr0 state UP group default qlen 1000
link/ether 10:60:4b:5c:c1:d3 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether a4:17:31:22:bf:b4 brd ff:ff:ff:ff:ff:ff
4: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 10:60:4b:5c:c1:d3 brd ff:ff:ff:ff:ff:ff
inet scope global vmbr0
valid_lft forever preferred_lft forever
inet6 fe80::1260:4bff:fe5c:c1d3/64 scope link
valid_lft forever preferred_lft forever

ip r
default via dev vmbr0 proto kernel onlink dev vmbr0 proto kernel scope link src

cat /etc/network/interfaces
# network interface settings; autogenerated
# Please do NOT modify this file directly, unless you know what
# you're doing.
# If you want to manage parts of the network configuration manually,
# please utilize the 'source' or 'source-directory' directives to do
# so.
# PVE will preserve these directives, but will NOT read its network
# configuration from sourced files, so do not attempt to move any of
# the PVE managed interfaces into external files!

auto lo
iface lo inet loopback

iface enp4s0 inet manual

auto vmbr0
iface vmbr0 inet static
bridge-ports enp4s0
bridge-stp off
bridge-fd 0

(I have removed wireless interface just in case)

I have access to from other computers in the same network in order to manage virtual environment but no internet access from proxmox host.

I have tried twice a fresh install with diferent IP.
Last edited:

What give you when you try to `ping` and/or `ping google.com`?

Maybe the issue related to the `/etc/resolv.conf` in your Proxmox VE host, which is not correct?
Hi Moayad. Thak you for your reply.

ping -c 4
PING ( 56(84) bytes of data.

--- ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3053ms

ping google.com -c 4
ping: google.com: Temporary failure in name resolution

cat /etc/resolv.conf

I have tried with nameserver too but same problem.
You could also test to set the DNS server IP as your router IP in the /etc/resolv.conf



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!