[SOLVED] No IOMMU detected


New Member
Jul 30, 2023
Edit: Solved with the ZFS section in https://www.reddit.com/r/Proxmox/comments/lcnn5w/proxmox_pcie_passthrough_in_2_minutes/

Hi, thank you for your time,

I have Intel vt-d (IOMMU) enabled in the motherboard, and I also tested with UNRAID and GPU passthrough works fine in there, but I keep getting this error on Proxmox.

MB: Asus x99-Deluxe II
CPU: Xeon E5-2683 v4

I have followed https://pve.proxmox.com/wiki/PCI_Passthrough, as well as https://www.reddit.com/r/homelab/comments/b5xpua/the_ultimate_beginners_guide_to_gpu_passthrough/, but it still keeps on saying No IOMMU detected.
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on iommu=pt pcie_acs_override=downstream,multifunction nofb nomodeset video=vesafb:off,efifb:off"

I have CSM disabled, running in UEFI, and tried turning on ACS Control and MCTP(either, both. none). Also tried with reinstalling Proxmox with 8.0.2

My goal is to passthrough one of my sata controller and LSI card to my TrueNAS VM, and my Quadro K600 onto a VM.

root@pve:~# dmesg | grep -e DMAR -e IOMMU
[ 0.012216] ACPI: DMAR 0x00000000BAF6E760 0000E4 (v01 ALASKA A M I 00000001 INTL 20091013)
[ 0.012241] ACPI: Reserving DMAR table memory at [mem 0xbaf6e760-0xbaf6e843]
[ 0.824815] DMAR: Host address width 46
[ 0.824818] DMAR: DRHD base: 0x000000fbffd000 flags: 0x0
[ 0.824827] DMAR: dmar0: reg_base_addr fbffd000 ver 1:0 cap 8d2008c10ef0466 ecap f0205b
[ 0.824833] DMAR: DRHD base: 0x000000fbffc000 flags: 0x1
[ 0.824840] DMAR: dmar1: reg_base_addr fbffc000 ver 1:0 cap 8d2078c106f0466 ecap f020df
[ 0.824845] DMAR: RMRR base: 0x000000bdb72000 end: 0x000000bdb80fff
[ 0.824850] DMAR: ATSR flags: 0x0
[ 0.824853] DMAR: RHSA base: 0x000000fbffc000 proximity domain: 0x0
[ 0.824858] DMAR-IR: IOAPIC id 1 under DRHD base 0xfbffc000 IOMMU 1
[ 0.824862] DMAR-IR: IOAPIC id 2 under DRHD base 0xfbffc000 IOMMU 1
[ 0.824865] DMAR-IR: HPET id 0 under DRHD base 0xfbffc000
[ 0.824869] DMAR-IR: x2apic is disabled because BIOS sets x2apic opt out bit.
[ 0.824870] DMAR-IR: Use 'intremap=no_x2apic_optout' to override the BIOS setting.
[ 0.825539] DMAR-IR: Enabled IRQ remapping in xapic mode
[ 13.317594] DMAR: [Firmware Bug]: RMRR entry for device 05:00.0 is broken - applying workaround
[ 13.317601] DMAR: [Firmware Bug]: RMRR entry for device 06:00.0 is broken - applying workaround
root@pve:~# dmesg | grep 'remapping'
[ 0.825539] DMAR-IR: Enabled IRQ remapping in xapic mode
[ 0.825544] x2apic: IRQ remapping doesn't support X2APIC mode


  • iommu.png
    13.1 KB · Views: 14
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!