New VMs have no network access


New Member
Sep 3, 2021
I'm relatively new to using Proxmox and linux in general. Been creating VMs for about 6 months using proxmox 6.3-4. Everything has worked and I have created ubuntu, openmediavault, and lubuntu VMs without issue. About 3 days ago I made a VM with default network settings (virtio, vmbr0) and it worked with no issue. There have been no network changes that I know of. Any new VM that I create has no internet access. I have tried creating different ones using each virtual network adapter model with no result. Looking for any info about steps to try to get this working. Let me know if there is any additional info I can provide.

Please post your Proxmox network configuration cat /etc/network/interfaces and the output of ip a and the VM config qm config {VMID}


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!