[SOLVED] new virtiofsd in Proxmox VE 8 appears broken


Active Member
Jul 29, 2018
Does anyone have a working example of a host virtiofsd command line, and a VMID.conf arg: line, that works with the "new" virtiofsd in proxmox 8?

I tried the arg: line I used from a pve7.4 VM (which worked fine once virtiofsd was running in 7.x) but it does not appear to work with version 8.

I see the example here, but once I put the qemu-system arguments in the args: line, virtiofsd starts in my hookscript, then dies. If I add --debug-level trace, no additional or relevant data is added that helps troubleshoot. It just dies. I've tried so many variations I've lost track... none of them have worked.

I currently have the following in my VMID.conf file:
args: -chardev socket,id=char0,path=/run/praxis-rcc.sock -device vhost-user-fs-pci,queue-size=1024,chardev=char0,tag=rcc -object memory-backend-file,id=mem,size=32G,mem-path=/dev/shm,share=on -numa node,memdev=mem

And run the following from my hookscript in the pre-start phase of the hookscript:
nohup /usr/libexec/virtiofsd --log-level trace --socket-path=/run/praxis-rcc.sock --shared-dir=/mnt/home/rcc --announce-submounts --inode-file-handles=mandatory  
&> /var/tmp/virtiofsd-start.out &

All I get in my virtiofs-start.out file is:
# cat /var/tmp/virtiofsd-start.out
nohup: ignoring input
[2023-07-06T00:29:41Z DEBUG virtiofsd::passthrough::mount_fd] Creating MountFd: mount_id=524, mount_fd=10
[2023-07-06T00:29:41Z DEBUG virtiofsd::passthrough::mount_fd] Dropping MountFd: mount_id=524, mount_fd=10
[2023-07-06T00:29:41Z INFO  virtiofsd] Waiting for vhost-user socket connection...

Before it dies on qmstart with no further output.

If I restart virtiofsd by hand, which appears to stay running using the same command line but started manually, then try to mount a directory in a guest (Ubuntu 23.04) with:
$ sudo mount -t virtiofs rcc /mnt/test/rcc
$ echo $?

But then:
ls /mnt/test/rcc
will hang.... forever!

Did anyone at proxmox test this before including it in Proxmox 8?

If so, what arg: line and host command line was used?
Thank you @fabian. I was able to get it working from the info provided.

I have also posted a Tutorial based on what I found here.

It may be of help to someone until virtiofsd becomes integrated with the WebUI.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!