Missing RAM - 128GB Shows as 2GB

EChondo

Member
Jul 20, 2019
2
1
8
51
Hello everyone,

Basically, I have a SuperMicro 1U with 128GBs of RAM installed. I just installed Proxmox fresh last night on it and it only ever registers 1.83GBs of RAM. The BIOS shows all four sticks populating and shows 128GBs, I tried swapping sticks in and out/different slots and nothing changed. I also made a Fedora Live USB and launched that and it saw 64GB with two sticks installed and then I rebooted and installed all four and Fedora was able to see all 4 sticks and 128GBs of RAM reported.

When I try to create a VM and launch it with more than 2GBs of RAM, the VM hangs and never starts. I was able to get a Fedora CT started with 1 core and 1GB of RAM and installed PiHole and everything is running fine.

Tried updating the kernel to the latest stable from Proxmox. The BIOS on the motherboard was dated back to 2018, version 1.3. I updated it to the most recent 2.3 released back in summer-2021.

Any advice? I'd love to use this system with even 1 stick of RAM, but even going down to 1 stick still shows 1.83GBs.

Hardware;
* SuperMicro 1U chassis
* X10SDV-TP8F Motherboard
* 128GB's of RAM(4x32GBs, SKHynix)
* 1x256GB NVME SSD
* 1x512GB SATA SSD

XJIuqfD.png


DmiDecode returns;
root@pve:~# dmidecode # dmidecode 3.3 /sys/firmware/efi/systab: SMBIOS entry point missing

Meminfo returns;
root@pve:~# cat /proc/meminfo MemTotal: 1920476 kB MemFree: 494468 kB MemAvailable: 648504 kB Buffers: 23552 kB Cached: 306592 kB SwapCached: 0 kB Active: 142836 kB Inactive: 1100860 kB Active(anon): 1128 kB Inactive(anon): 977424 kB Active(file): 141708 kB Inactive(file): 123436 kB Unevictable: 30856 kB Mlocked: 30856 kB SwapTotal: 8388604 kB SwapFree: 8388604 kB Dirty: 1052 kB Writeback: 0 kB AnonPages: 944452 kB Mapped: 148208 kB Shmem: 50232 kB KReclaimable: 39952 kB Slab: 84660 kB SReclaimable: 39952 kB SUnreclaim: 44708 kB KernelStack: 3852 kB PageTables: 9960 kB NFS_Unstable: 0 kB Bounce: 0 kB WritebackTmp: 0 kB CommitLimit: 9348840 kB Committed_AS: 4140908 kB VmallocTotal: 34359738367 kB VmallocUsed: 39600 kB VmallocChunk: 0 kB Percpu: 776 kB HardwareCorrupted: 0 kB AnonHugePages: 0 kB ShmemHugePages: 0 kB ShmemPmdMapped: 0 kB FileHugePages: 0 kB FilePmdMapped: 0 kB HugePages_Total: 0 HugePages_Free: 0 HugePages_Rsvd: 0 HugePages_Surp: 0 Hugepagesize: 2048 kB Hugetlb: 0 kB DirectMap4k: 126816 kB DirectMap2M: 1865728 kB DirectMap1G: 0 kB
 

EChondo

Member
Jul 20, 2019
2
1
8
51
Hey everyone, I fixed my own issue.

So during my troubleshooting I had to re-install Proxmox via UEFI, but also had to enable Secure Boot and do Standard settings for Secure Boot, otherwise even using UEFI my RAM wasn't showing up properly. Previously I always had Secure Boot as disabled, and Legacy and UEFI didn't make a difference otherwise.

Now I have the full amount showing on the Summary view. Gonna need to play around with allocations and VMs/CTs to make sure its actually useable, but it is looking really good so far.

Hopefully this helps someone in the future.

UMF2FQp.png


Oh and this also fixed my DmiDecode issue with the "SMBIOS entry point missing" error.

DmiDecode now shows;
root@pve:~# dmidecode # dmidecode 3.3 Getting SMBIOS data from sysfs. SMBIOS 2.8 present. 50 structures occupying 2858 bytes. Table at 0x000ED9B0. Handle 0x0000, DMI type 0, 24 bytes BIOS Information Vendor: American Megatrends Inc. Version: 2.3 Release Date: 05/07/2021 Address: 0xF0000 Runtime Size: 64 kB ROM Size: 16 MB Characteristics: PCI is supported BIOS is upgradeable BIOS shadowing is allowed Boot from CD is supported Selectable boot is supported BIOS ROM is socketed EDD is supported 5.25"/1.2 MB floppy services are supported (int 13h) 3.5"/720 kB floppy services are supported (int 13h) 3.5"/2.88 MB floppy services are supported (int 13h) Print screen service is supported (int 5h) 8042 keyboard services are supported (int 9h) Serial services are supported (int 14h) Printer services are supported (int 17h) ACPI is supported USB legacy is supported BIOS boot specification is supported Targeted content distribution is supported UEFI is supported BIOS Revision: 5.6 Handle 0x0001, DMI type 1, 27 bytes System Information Manufacturer: Supermicro Product Name: SYS-5018D-FN8T Version: 0123456789 Serial Number: REMOVED UUID: 00000000-0000-0000-0000-ac1f6b6f2324 Wake-up Type: Power Switch SKU Number: To be filled by O.E.M. Family: To be filled by O.E.M.
 
  • Like
Reactions: Dunuin

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!