LXC Container - Errors / Warnings - ubuntu / debian

Tux_1024

New Member
Mar 7, 2021
20
14
3
29
Germany
I tried out the LXC containers recently.

First I tried the debian template (debian-10-standard_10.7-1_amd64.tar.gz), downloaded via PVE Web GUI, created a new container via PVE Web GUI, set my hostname (debian) and password, for the network chose DHCP and left everything as default. However when I start up the container and try to connect to the console via the Web GUI. I was just gerettet with a black screen, even after pressing enter nothing changed...
debianblack.png

hm, okay what's wrong ? So i tried the ubuntu template (ubuntu-20.04-standard_20.04-1_amd64.tar.gz), downloaded it via the Web GUI, created a new container via PVE Web GUI, set my hostname (ubuntu) and password, for network chose DHCP and left everything as default. Then fired up the container and voila, a login screen.
ubuntulogin.PNG
I was setting up ubuntu and everything i tried worked so far (ssh, add users, changing passwords...)

Then i checked back to the still running debian container and oh, all so a login screen after approx. 5 to 10 minutes...
debianlogin.png
So I tried some things in debian. I ran into some problems... every time I restart the container the just enabled ssh service won't come up automatically an some more things just won't work... so I dug down deeper...

I started the debain container manually in debug mode via:
Code:
lxc-start -lDEBUG -o debian.log -F -n 100

and immediately saw some errors and why my debian container took so long to boot...
debianaudit.png
debiankernel.PNG
debianstartnet.PNG

I did the same for ubuntu no startup error messages. Puh okay so maybe there is just something wrong with the debian container?
I took a look at the log files. And in noticed some errors that are in common to bot containers bevor the OS's start:

Code:
lxc-start 100 20210310210625.237 ERROR    utils - utils.c:__safe_mount_beneath_at:1106 - Function not implemented - Failed to open 54(dev)

lxc-start 100 20210310210625.299 ERROR    utils - utils.c:__safe_mount_beneath_at:1106 - Function not implemented - Failed to open 57(full)
lxc-start 100 20210310210625.299 DEBUG    conf - conf.c:lxc_fill_autodev:1230 - Bind mounted host device node "/dev/full" onto "full"
lxc-start 100 20210310210625.299 ERROR    utils - utils.c:__safe_mount_beneath_at:1106 - Function not implemented - Failed to open 57(null)
lxc-start 100 20210310210625.299 DEBUG    conf - conf.c:lxc_fill_autodev:1230 - Bind mounted host device node "/dev/null" onto "null"
lxc-start 100 20210310210625.299 ERROR    utils - utils.c:__safe_mount_beneath_at:1106 - Function not implemented - Failed to open 57(random)
lxc-start 100 20210310210625.299 DEBUG    conf - conf.c:lxc_fill_autodev:1230 - Bind mounted host device node "/dev/random" onto "random"
lxc-start 100 20210310210625.299 ERROR    utils - utils.c:__safe_mount_beneath_at:1106 - Function not implemented - Failed to open 57(tty)
lxc-start 100 20210310210625.299 DEBUG    conf - conf.c:lxc_fill_autodev:1230 - Bind mounted host device node "/dev/tty" onto "tty"
lxc-start 100 20210310210625.299 ERROR    utils - utils.c:__safe_mount_beneath_at:1106 - Function not implemented - Failed to open 57(urandom)
lxc-start 100 20210310210625.299 DEBUG    conf - conf.c:lxc_fill_autodev:1230 - Bind mounted host device node "/dev/urandom" onto "urandom"
lxc-start 100 20210310210625.299 ERROR    utils - utils.c:__safe_mount_beneath_at:1106 - Function not implemented - Failed to open 57(zero)
lxc-start 100 20210310210625.299 DEBUG    conf - conf.c:lxc_fill_autodev:1230 - Bind mounted host device node "/dev/zero" onto "zero"

lxc-start 100 20210310211430.507 INFO     error - error.c:lxc_error_set_and_log:33 - Child <4748> ended on signal (2)

lxc-start 100 20210310211430.711 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/unified//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.711 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/unified//lxc.monitor/100"
lxc-start 100 20210310211430.711 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/unified//lxc.monitor/100"
lxc-start 100 20210310211430.711 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/systemd//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.711 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/systemd//lxc.monitor/100"
lxc-start 100 20210310211430.711 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/systemd//lxc.monitor/100"
lxc-start 100 20210310211430.711 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/rdma//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.711 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/rdma//lxc.monitor/100"
lxc-start 100 20210310211430.711 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/rdma//lxc.monitor/100"
lxc-start 100 20210310211430.733 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/cpuset//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.733 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/cpuset//lxc.monitor/100"
lxc-start 100 20210310211430.733 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/cpuset//lxc.monitor/100"
lxc-start 100 20210310211430.733 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/blkio//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.733 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/blkio//lxc.monitor/100"
lxc-start 100 20210310211430.733 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/blkio//lxc.monitor/100"
lxc-start 100 20210310211430.733 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/memory//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/memory//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/memory//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/devices//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/devices//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/devices//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/pids//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/pids//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/pids//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/hugetlb//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/hugetlb//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/hugetlb//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/cpu,cpuacct//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/cpu,cpuacct//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/cpu,cpuacct//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/perf_event//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/perf_event//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/perf_event//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/net_cls,net_prio//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/net_cls,net_prio//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/net_cls,net_prio//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/freezer//lxc.monitor/100/lxc.pivot"
lxc-start 100 20210310211430.734 WARN     utils - utils.c:lxc_rm_rf:1895 - Device or resource busy - Failed to delete "/sys/fs/cgroup/freezer//lxc.monitor/100"
lxc-start 100 20210310211430.734 WARN     cgfsng - cgroups/cgfsng.c:cgfsng_monitor_destroy:1103 - Failed to destroy "/sys/fs/cgroup/freezer//lxc.monitor/100"

my thoughts... hmm something seems to be not right here... maybe related to my new hardware (2020) , so I tried it on a diffrent machine older hardware (2010), same results...

also noticed the douddble slash "//" in some warnings...
I searched the Proxmox buggzilla tracker but found nothing related.

Since the container is unable to bind some host devices, I've all so tried it on a pivileged container same results...

so my questions are:
0. Should i file a bug report?
1. Why has debain trouble with the network startup?
2. Are these errors/warnings related to my setups?
3. Has anybody else the same warnings/errors?
4. Does someone know how get rid of those warnings/errors knows a solution?
5. Can I savely ignore them or will they cause some problems later on?
6. Are there more infos you need ? hardware specs of my setup etc ?

I'm happy about any answer or tip or hint I could try out!
 

Attachments

  • ubuntu.PNG
    ubuntu.PNG
    13.8 KB · Views: 1
  • debian.log
    24.3 KB · Views: 1
  • ubuntu.log
    24.3 KB · Views: 0
  • paketversions.txt
    1.2 KB · Views: 0
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,756
787
163
33
Vienna
did you maybe select 'dhcp' for ipv6 too and you do not have an dhcpv6 server in your network? this would explain such a minute long delay for the login (since i think the dhcp timeout is 5min)
 
  • Like
Reactions: Tux_1024

Tux_1024

New Member
Mar 7, 2021
20
14
3
29
Germany
Oh my... indeed you are right!!! I set the DHCP IPv6 to static, debian ct boots right up as fast as ubuntu ct does, ssh service is working!
Thanks a lot for pushing me in the right direction!

I checked again the error messages related to the failed binding of the host devices.... they only appear on a unprivileged container... it was late last night... my fault again... so I guess these are fine, right?

Only the first Error won't go away, even on a privileged ct on both machines (old and new, both Intel CPU's)...
lxc-start 100 20210310210625.237 ERROR utils - utils.c:__safe_mount_beneath_at:1106 - Function not implemented - Failed to open 54(dev)
anything I can do about that? Or just ignore it ?
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,756
787
163
33
Vienna
Or just ignore it ?
i guess if everything works as expected, you can just ignore it.

I checked again the error messages related to the failed binding of the host devices.... they only appear on a unprivileged container... it was late last night... my fault again... so I guess these are fine, right?
yes, AFAIK starting an unprivileged container as a privileged user does not work correctly

Oh my... indeed you are right!!! I set the DHCP IPv6 to static, debian ct boots right up as fast as ubuntu ct does, ssh service is working!
Thanks a lot for pushing me in the right direction!
great :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!