[SOLVED] Letsencrypt request: SSLError: ("bad handshake: Error([('SSL routines', 'ssl3_read_bytes', 'tlsv1 al

Michel V

Well-Known Member
Jul 5, 2018

I am running the script from IT Niels to update my LetsEncrypt certs. I successfully obtained certs before, but now ran into this cryptic error:

Disable firewall
Updating certificate
Saving debug log to /var/log/letsencrypt/letsencrypt.log
An unexpected error occurred:
SSLError: ("bad handshake: Error([('SSL routines', 'ssl3_read_bytes', 'tlsv1 alert internal error')],)",)
Please see the logfiles in /var/log/letsencrypt for more details.
Writting certificates to proxmox
LetsEncryptProxmox.sh: line 64: /etc/pve/nodes/controller.cloud/pve-ssl.key: No such file or directory
LetsEncryptProxmox.sh: line 66: /etc/pve/nodes/controller.cloud/pve-ssl.pem: No such file or directory
Enable firewall
Restarting proxmox service
All done! :)

Script here: itniels.dk/virtualization/proxmox/proxmox-and-letsencrypt-certificates/

Internet searches give unclear responses/clues.

Also note that using the GUI in 5.2 gives me no luck, and running command line update with certbot gives this exact error.

Anyone any idea?
Sorry for being overcomplete.

I retried with root as user (ahum) and disabling the firewall (ok, 80 needs open, maybe we can we forse https validation later on?)



The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!