LACP (balance-tcp) bonding with Cisco Catalyst WS-C4948-10GE-S

Chipchilinka

New Member
Aug 24, 2021
1
0
1
27
Through ovs-vsctl, bridges from physical interfaces are configured in the GUI
eno1 - Service NIC
eno2 - Man NIC
eno3 + eno4 - bond (LACP (balance-tcp))

Cisco shows the following error for server ports configured as bond:
Code:
%EC-5-L3DONTBNDL2: Gi1/35 suspended: LACP currently not enabled on the remote port
%EC-5-L3DONTBNDL2: Gi1/36 suspended: LACP currently not enabled on the remote port

Interfaces config:
Code:
auto lo
iface lo inet loopback

auto eno1
iface eno1 inet manual
        ovs_type OVSPort
        ovs_bridge vmbr1

auto eno2
iface eno2 inet manual
        ovs_type OVSPort
        ovs_bridge vmbr0

auto eno3
iface eno3 inet manual

auto eno4
iface eno4 inet manual

auto vlan1185
iface vlan1185 inet static
        address 10.225.2.21/24
        ovs_type OVSIntPort
        ovs_bridge vmbr2
        ovs_options tag=1185

auto bond0
iface bond0 inet manual
        ovs_bonds eno3 eno4
        ovs_type OVSBond
        ovs_bridge vmbr2
        ovs_options lacp=active bond_mode=balance-tcp

auto vmbr1
iface vmbr1 inet static
        address 10.225.1.21/24
        gateway 10.225.1.1
        ovs_type OVSBridge
        ovs_ports eno1
#Management

auto vmbr0
iface vmbr0 inet manual
        ovs_type OVSBridge
        ovs_ports eno2
#Service

auto vmbr2
iface vmbr2 inet manual
        ovs_type OVSBridge
        ovs_ports bond0 vlan1185
#Backup and Migrations

Cisco config for PortChannel:
Code:
interface Port-channel1
 description srv25 NIC 3,4
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1185
 switchport mode trunk
 spanning-tree bpdufilter enable
end

Cisco config for NICs:
Code:
interface GigabitEthernet1/3
 description srv25 NIC3 (backup and migrate)
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1185
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
end

interface GigabitEthernet1/4
 description srv25 NIC4 (backup and migrate)
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1185
 switchport mode trunk
 channel-protocol lacp
 channel-group 1 mode active
end
Despite this, the channel bandwidth is not more than 1Gb/s, although it should have been 2Gb/s

What could be the problem?
 
Are you referring to this bandwidth?
Code:
Port-channel2 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is ---- (bia ----)
  Description: LAN_LACP
  MTU 1500 bytes, BW 4000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255

I am using linux bonds (not ovs) with a 3560E switch and it has been working fine for me. Compared to your interfaces config mine looks way different but I am assuming that might be because I am using linux bonds and not ovs. Also, my switch configs look different from yours as well.

Interfaces
Code:
auto lo
iface lo inet loopback

# eno1 and eno2 embedded NIC for ISP
iface eno1 inet manual

iface eno2 inet manual

# enp8s0fx NIC PCIE card for LAN
iface enp8s0f0 inet static

iface enp8s0f1 inet static

iface enp8s0f2 inet static

iface enp8s0f3 inet static

# bond0 for LAN LACP
auto bond0
iface bond0 inet static
      bond-slaves enp8s0f0 enp8s0f1 enp8s0f2 enp8s0f3
      bond-miimon 100
      bond-mode 802.3ad
      bond-xmit-hash-policy layer3+4

# bond1 for ISP/WAN
auto bond1
iface bond1 inet manual
      bond-slaves eno1 eno2
      bond-miimon 100
      bond-mode 802.3ad
      bond-xmit-hash-policy layer3+4

# vmbr0 management/LAN
auto vmbr0
iface vmbr0 inet static
        address x.x.x.x/24
        netmask 255.255.255.0
        gateway x.x.x.x
        bridge-ports bond0
        bridge-stp off
        bridge-fd 0

# vmbr1 for ISP/WAN
auto vmbr1
iface vmbr1 inet manual
        bridge-ports bond1
        bridge-stp off
        bridge-fd 0

Switch config
Code:
interface Port-channel2
 description LAN_LACP
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
end

interface GigabitEthernet0/13
 description <- LAN_LACP ->
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast
 channel-protocol lacp
 channel-group 2 mode passive
end

Output of show etherchannel summary
Code:
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
2      Po2(SU)         LACP      Gi0/13(P)   Gi0/14(P)   Gi0/15(P)
                                 Gi0/16(P)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!