kernel panic when creating VMs (centos 9 stream ISO)

scottharwell

New Member
Mar 10, 2022
1
0
1
41
Another circumstance where this can arise is when running CentOS Stream or RHEL 9 containers under a VM running in Proxmox. For instance, running a CentOS Stream 9 container on RHEL 8 or CentOS 8 (or any other RHEL 8 derivative) will generate the same error within the container itself. Changing the CPU for the host VM appears to fix those container issues as well.
 
Last edited:

ramblurr

New Member
Oct 24, 2020
12
2
3
I'm encountering this issue with the latest 2022-04-19 centos stream 9 image as well (CentOS-Stream-GenericCloud-9-20220419.0.x86_64.qcow2).

passing `--cpu cputype=host` when creating the vm worked for me as well.

I'm also curious, what is he effect of choosing `host`? Are there drawbacks? What happens when the vm is migrated to a different host?
 

alebeta

Active Member
Mar 20, 2018
44
3
28
31
gonkar.com
Hi @ramblurr

the effects depend on what are you doing with proxmox and your configuration.

What I can tell you is: If you have a cluster and each node in the cluster have dfferent cpus, when live migrating, you can find some problems related with cpu.

Other than that I believe it is fine. But for sure other members of the forum can share more from their experience
 

jterry

New Member
Jan 20, 2022
1
0
1
56
Hello,

I've tried AlmaLinux 9.0 today and had this problem.

The Processor Type -> host workaround worked for me.
 

Baulder

Member
Jul 19, 2018
2
4
23
Russia
I've tried OracleLinux 9 today and had this problem.

The Processor Type -> host workaround not working for me.

My CPU is Intel Xeon E5410. May be this CPU does not contains the x86-64-v2 instructions
 

BAMBR

Member
May 27, 2019
1
0
6
40
Hello all, if add cpu with instruction on cpu-models.conf, all worked normal.
my example:
cpu-model: avx+sse
flags +fpu;+de;+pse;+tsc;+msr;+pae;+mce;+cx8;+apic;+sep;+mtrr;+pge;+mca;+cmov;+pat;+pse36;+clflush;+mmx;+fxsr;+sse;+sse2;+syscall;+nx;+pdpe1gb;+rdtscp;+lm;+pni;+pclmulqdq;+ssse3;+cx16;+sse4_1;+sse4_2;+movbe;+popcnt;+aes;+xs
ave;+rdrand;+lahf_lm;+abm;+fsgsbase;+bmi1;+smep;+bmi2;+adx;+smap;+clflushopt;+xsaveopt;+xgetbv1;+arat;+hypervisor;+avx
phys-bits host
hidden 0
hv-vendor-id proxmox
reported-model kvm64
 

mount

New Member
Jul 15, 2022
1
0
1
It worked for me on Proxmox VE 6.2

/etc/pve/virtual-guest/cpu-models.conf
cpu-model: rhel9
flags +ssse3;+sse4_1;+sse4_2;+popcnt
phys-bits host
hidden 0
hv-vendor-id proxmox
reported-model kvm64

# qm set 100 --cpu=custom-rhel9
 

jameswang

New Member
Mar 10, 2022
12
1
3
55
i've just tried that now too, it seems to work fine with the host CPU type, thanks for checking!


no idea, but it works with the CPU type set to host.

if you have similar issues in different hypervisors then it might be a bug on centos' end (would make sense to report it to them if that's the case)
FYI, I had same problem when tried to install Rocky 9 on PVE 7.2 (change CPU type to 'host' fixed it). I tried the same ISO on ESXi 5.5 and was able to install it.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!