[SOLVED] intel DC P4510 passthrough failure


Jun 3, 2020
Czech republic
I'm trying to passtrought a pcie nvme ssd to virtual machine. I'm not using a HBA, but each ssd is directly connected to pcie connector.
I followed up: pcie passthrough guide. IOMMU is enabled and working, all required modules are also enabled.
Also the nvme drive is using the latest firmware available:
intel ssd.JPG
My HW:
CPU: Ryzen 3600
RAM: 64GB of unbuffered ECC (ECC is working checked in Memtest86)
MB: B450M Pro4-F (suports: IOMMU isolation, interrupt remapping)
in UEFI: IOMMU is enabled, virtualization also.

Settings for Windows test machine:
agent: 1
bios: ovmf
boot: order=scsi0;ide2;net0
cores: 4
cpu: host
efidisk0: local-lvm:vm-102-disk-1,size=4M
ide2: local:iso/Windows10_20H1.iso,media=cdrom
machine: pc-q35-6.0
memory: 4096
name: test
net0: virtio=82:16:EF:BF:37:30,bridge=vmbr0,firewall=1
numa: 0
ostype: win10
scsi0: local-lvm:vm-102-disk-0,discard=on,size=40G,ssd=1
scsihw: virtio-scsi-pci
smbios1: uuid=11bbd3f8-7941-4a79-9bad-49d241bf164d
sockets: 1
vmgenid: b5224769-02c8-4c1e-b8f2-617539a750d2

Settings for FreeBSD machine (TrueNAS test)
agent: 1
balloon: 0
bios: ovmf
boot: order=scsi0;net0
cores: 4
cpu: host
efidisk0: local-lvm:vm-100-disk-1,size=4M
hostpci0: 0000:01:00,pcie=1
machine: q35
memory: 16384
name: TrueNAS
net0: virtio=32:E1:6C:C0:16:93,bridge=vmbr0,firewall=1
numa: 0
ostype: l26
scsi0: local-lvm:vm-100-disk-0,discard=on,size=20G,ssd=1
scsihw: virtio-scsi-pci
smbios1: uuid=f9680fd1-33d5-4d51-8608-3b3a92105644
sockets: 1
vmgenid: bcf3dc3b-dad1-4784-b016-ab9b3bb48e33

But whatever I try any combination in Add: PCI Device window like:
All functions: yes/no
ROM-Bar: yes/no
PCI-Express: yes/no

I always end up with bricked proxmox and I need to perform hard restart via button on physical machine. The WebUI stops working and SSH too.
And it shows errors like:

In the past I tried gpu passthrough and I have never faced these errors and the gpu passthrough was also performed on the same hardware as this.

Thank you for any advice.
how are youre iommu groups split ? maybe the root disk is in the same group as the disk you want to passthrough?
how are youre iommu groups split ? maybe the root disk is in the same group as the disk you want to passthrough?
Hi, thanks for the reply. I just wanted to close this thread because I forgot to enable: ACS (Access Control Services) in UEFI and now it's working.
I know that for every device You need to have separated IOMMU group. But I mistakenly thought I had everything set up correctly and it still didn't work so I created this thread.
But after couple hours of break I realised that it might be disabled in UEFI and of course it was disabled :D


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!