Inherited a proxmox server. No ipv6 resolution

Jan 11, 2019
I recently inherited a new proxmox server. It seems to have some ipv6 issues.
When I run "apt-get update && apt-get upgrade && apt-get dist-upgrade" it hangs. If I run
"apt-get -o Acquire::ForceIPv4=true update && apt-get -o Acquire::ForceIPv4=true upgrade && apt-get -o Acquire::ForceIPv4=true dist-upgrade" it works.

I need help troubleshooting this. Please help.

Edit: After waiting for a long time (approx 10 mins), this command worked. What could be causing this?
Rerunning the command results in a similarly long wait time.

All other ipv6 devices on the same network work just fine.
Last edited:
For the next upgrade of your PVE server, please omit the 'apt-get upgrade' step. It is stated everywhere to use dist-upgrade, if you just use upgrade you will break something someday.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!