[SOLVED] ifupdown2: ovs_extra parameter


Active Member
Dec 15, 2015
After upgrading to ifupdown to ifupdown2 (as part of PVE7), I have a problem to configure NetFlow with ovs_extra in /etc/network/interfaces. Following statement worked in ifupdown:
ovs_extra --id=@nf create NetFlow targets=\"\" active_timeout=60 -- set Bridge vmbr0 netflow=@nf

In ifupdown2 this results in following error and the bridge does not come up:
ovs|00001|vsctl|INFO|Called as /usr/bin/ovs-vsctl ... --id=@nf create NetFlow targets= " " active_timeout=60 -- set Bridge vmbr0 netflow=@nf
ovs|00002|db_ctl_base|ERR|targets=: argument does not end in "=" followed by a value.

The targets parameter expects are string. I tried: targets="\"\"" or targets="" which results errors as well.
ovs|00002|db_ctl_base|ERR| unexpected ":" parsing set of 1 or more strings

Anybody knows the correct syntax?

Best Dirk
No, doesn't work. Seems that backslash is translated into space.
targets= :9995
After some trial and error I found a solution targets='""' translates to "targets=\"\""


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!